x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

What's causing fuzzy edges when in motion?

What is causing this ugly edge effect when in motion? I've tried all the AA settings and disabled motion blur, didn't help.

alt text

Product Version: Not Selected
Tags:
ue4_funnyedges.jpg (18.3 kB)
more ▼

asked Jul 22 '14 at 01:19 AM in Rendering

avatar image

Gigantoad
106 9 13 21

avatar image Jacky Jul 22 '14 at 01:24 AM

Do you have a Scene Capture 2D actor in your level?

avatar image Gigantoad Jul 22 '14 at 02:44 AM

Nope. Also it happens with a clean default level too.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

5 answers: sort voted first

Go to "Render settings > Motion Blur" and uncheck it.

more ▼

answered Apr 01 '16 at 11:02 AM

avatar image

_SeveneduS_
1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I was told by a UE developer that the answer might lie somewhere in the Post Process node. The node is so huge though, that I decided to put that quest off for another day... :p

more ▼

answered Jul 22 '14 at 03:26 AM

avatar image

Zeustiak
1.8k 131 68 110

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

You said you disabled motion blur; did you make sure to disable it in every relevant post process volume AND in whatever camera you're using?

If so, does this happen when launching in a standalone game instead of viewport mode?

more ▼

answered Jul 22 '14 at 05:03 AM

avatar image

Weaver
266 10 20 27

avatar image Gigantoad Jul 22 '14 at 12:59 PM

There's only one post process volume and the camera has it disabled too. And starting in standalone game shows the same thing.

However, I just noticed that it doesn't seem to be the case when I start in VR mode! I probably never noticed because the Rift resolution is so low, but starting in VR mode without the Rift shows that everything stays sharp including shadows from the moving object.

So now it's a case of finding what changes for the better in VR mode.

avatar image Gigantoad Jul 27 '14 at 06:44 PM

Hmm any more ideas anyone?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

That a down-sampled buffer being mixed into your final render for some type of post-processing effect. Probably quarter resolution by the look of your screenshot.

Use 'r.CompositionGraphDebug' while it's running and you can see the list of input and output buffers for the whole render. Most things have a meaningful name (like "VelocityBlurX") so you should be able to figure out what type of post-processing is still happening. Experiment with turning things on and off, and you should be able to find the culprit.

My guess would be that motion blur is still on somehow, but I couldn't know for sure without seeing the debug information.

more ▼

answered Aug 03 '14 at 06:39 PM

avatar image

CaptainScience
1 1

avatar image Gigantoad Aug 04 '14 at 01:28 AM

It's a blueprint-only project for now. Any way I can get this info without code?

avatar image CaptainScience Aug 04 '14 at 05:48 AM

I guess I didn't mention that that's actually a console command. While you're running the project you can press tilde key to bring up the console and type in commands. It's useful for changing settings and getting information at runtime. In the graphics programming documentation (https://docs.unrealengine.com/latest/INT/Programming/Rendering/index.html) there is a whole list of commands that you might find useful. There are lots of others though that you can look into if you're interested.

avatar image Gigantoad Aug 04 '14 at 01:08 PM

Oh right, should have figured that out on my own. Sorry about that.

There's lots of stuff in the resulting gml file, I'll try if I can find something.

avatar image Gigantoad Aug 04 '14 at 04:01 PM

So I've got a nice diagram now but don't know what to do with it. You know, I've disabled the whole postprocessing volume but the issue persists. Should I assume then that the problem lies elsewhere?

avatar image CaptainScience Aug 04 '14 at 04:17 PM

Anything on that list is still being rendered so those are the things you need to investigate. Go through the list and alter the settings for everything you see until the problem disappears (or gets worse). You should, for example, see where your antialiasing is applied so try altering those settings or disabling it to see if it changes anything. Keep following the chain of buffers back until you get to the start of the render. Somewhere in there is your problem. If you've disabled most of your post-processing it should be a pretty short chain.

avatar image Gigantoad Aug 04 '14 at 06:17 PM

So I've disabled the whole post process volume and executed the command again. The result is a diagram with one root node and nothing else. But the issue is still there.

Maybe it's a rendering bug after all?

avatar image Gigantoad Aug 04 '14 at 06:25 PM

Actually, scratch that. I just forgot to do a hierarchical view of the new diagram. I've also not disabled post process per se, just the volume...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Did you try creating a post processing volume and setting TemporalAA to FXAA?

more ▼

answered Aug 04 '14 at 06:54 AM

avatar image

xC0DEB10C
303 12 117 40

avatar image Gigantoad Aug 04 '14 at 01:12 PM

Yes indeed I use FXAA because temporal looks wrong in VR. Tried disabling it too, still the same issue.

Interstingly enough, like I mentioned earlier, when playing in the Rift the fuzzy edges are gone.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question