x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unknown cook failure (Android)

I followed the instructions on UE4 for building android games so I have set up the NVPACK and VS2017 as instructed.

But however I try to package the game it always fails with "UnknownCookFailure" (with no red or yellow error lines). I tried reinstalling,running as admin and with various project settings.

The problem occurs even if I try to build the default "2Dside scroller"(mobile) game that is shipped with UE4 as a template.

Logs are attached below,thanks.

UAT log

saved log

Product Version: UE 4.18
Tags:
uat-log.txt (37.9 kB)
save-log.log (75.4 kB)
more ▼

asked Nov 26 '17 at 10:18 PM in Packaging & Deployment

avatar image

Arremer
16 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Turns out I was unable to build only Android(ASTC). Once I removed ASTC from Android(multi) build inside Android project settings it worked fine.

Still not sure why ASTC is failling to build.

more ▼

answered Dec 04 '17 at 03:42 PM

avatar image

Arremer
16 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Are you packaging with Gradle?

It appears you have not accepted SDK license according to this line -

[2017.11.26-21.15.37:658][799]PackagingResults: Error: License not accepted. SDK License must be accepted in the Android project settings to deploy your app to the device.

Also, have you tried deleting your build, intermediate and saved folder and package again? (Offcourse, make backups)

Try pacakging with SDK API lvl and NDK Level to "latest" without the quotes.

more ▼

answered Nov 27 '17 at 05:33 AM

avatar image

SHOBBIT
650 13 13 27

avatar image Arremer Nov 27 '17 at 03:18 PM

I tried both Gradle and Ant, accepted the license after I saw the error,and tried deleting those folders and migrating to a clean project. I will give a look at your last suggestion.

avatar image Arremer Nov 27 '17 at 08:19 PM

Tried setting levels to "latest" (was android-19) still nothing. It must be something with plugins or SDK tools since I cant package default Android games.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question