x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Black spots appearing on static mesh

I've been trying to figure this problem out for a long time and it's really pissing me off, so I made a static mesh of a brick wall in blender and exported it to unreal like usual, but when I built the lighting, it had black spots all over it. It used to be worse, the entire mesh was covered in black but I made it a little better by adding the lightmap in blender. This has been a problem for me for a very long time so please help, but thanks in advance.alt text alt text

Product Version: UE 4.14
Tags:
2017-11-28-6.png (794.2 kB)
2017-11-28-8.png (263.2 kB)
more ▼

asked Nov 29 '17 at 02:19 PM in Rendering

avatar image

SocialistSnek
1 1 2 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi!

The picture you've attached is still under build... how does it look like AFTER it? And as you see your lightmap is not ok!! ...I guess it's an automatically generated one and where you have the seams you have the black artifacts... I guess having a proper lightmap would solve your problem!

Good luck!

more ▼

answered Nov 29 '17 at 05:12 PM

avatar image

Makigirl
1.2k 3 4 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Generally, when you have black 'spots' on the mesh, your lightmap could have problems with this. The errors you are receiving means that your mesh hasn't been properly UV unwrapped in Blender. Make sure that you have no overlaps on your UV before you export from blender. You will also need to make sure that your UV islands have enough space between them that the lightmap doesn't bleed over onto a nearby UV island.

Because that is a wall, it'd be easy to just planar map it to make sure your UVs are correct.

Other reasons you can end up with black spots:

  • Lightmap resolution is too low. The default lightmap resolution on a static mesh is 64. If the mesh is large, you need to increase this to 128 or 256 and rebuild the lighting. It will get rid of black seams (usually where two meshes overlap or connect).

  • You have enabled distance field ambient occlusion and are getting artifacts from it.

  • You are using a material that is creating artifacts (such as incorrect blends)

more ▼

answered Nov 29 '17 at 06:00 PM

avatar image

Nice_Rain
249 13 14 30

avatar image SocialistSnek Dec 02 '17 at 12:17 AM

Can you link to a video tutorial on how to do these because nothing seems to be working, especially now that I've baked a lightmap only to find out that you cannot import baked lightmaps into ue4.

avatar image Nice_Rain Dec 02 '17 at 12:18 AM

What did you bake your lightmaps as? A .jpg texture? You can still import those. Set the .jpg texture to the 'emissive' part of your material. It will not receive shadowing from the light but it should still work (I've done it before).

avatar image Nice_Rain Dec 02 '17 at 12:25 AM

I'm not sure how to UV map in blender, I only use 3ds Max. I found this link that talks about the basics of UV mapping in blender (this should help with overlapping UVs).

https://en.wikibooks.org/wiki/Blender_3D:_Noob_to_Pro/UV_Map_Basics

avatar image Nice_Rain Dec 02 '17 at 12:25 AM

To change your lightmap resolution, you need to click on the static mesh you imported, and navigate to the setting titled "Override lightmap resolution." Change the number to 256 and try again. I posted an image below of the setting:

alt text

avatar image SocialistSnek Dec 03 '17 at 03:54 AM

When I add the lightmap into the material as the emissive, it changes the outer appearance of the whole material, acting like its the diffusealt text

2017-12-02.png (420.3 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question