Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

MP4 video no longer works in 4.18 for Android

We are trying to package the project with a single video. It's a base level with a mp4 video. It works very well with 4.17 version. We made all changes for the new frameworks. But it doesn't work. In PC it works.

Product Version: UE 4.18
more ▼

asked Nov 29 '17 at 06:47 PM in Packaging & Deployment

avatar image

6 1 3 2

avatar image smbv1 Jan 17 '18 at 12:27 AM

I have the same problem in 4.18.2, can't compile for android.

avatar image tgraupmann Jan 17 '18 at 12:29 AM

Can't compile for Android? In my case it always compiled, it's just video playback didn't work. You likely are just missing a dependency. You'll want to install Nvidia Codeworks to get the compile dependencies. And then in your project settings enable Android. There wasn't much to configure after that.

avatar image smbv1 Jan 17 '18 at 12:32 AM

Sorry, I can compile, but the video doesn't play on the material. Is there any other way to make the animated material to play, at least 50 frames sequence of images?

avatar image tgraupmann Jan 17 '18 at 12:34 AM

I stayed on 4.17 to get video playback working that follows the documented way to do it. That said, UE4 Staff have commented on my thread about the steps needed to make it work in 4.18. I have not verified that it works. If you can make it work, plz let me know. - https://answers.unrealengine.com/questions/740083/android-streaming-mediaplayer-clearing-gl-error-0x.html Thanks!

avatar image IslandPlaya Feb 07 '18 at 11:33 AM

Has anyone come up with a solution for this? I tried using a material with external sampler source and UI domain instead of directly using the media texture as suggested elsewhere. Still no video output on Android but works fine on windows. I'd hate to have to go back to 4.17 just because of this. Cheers.

avatar image IntervideoFilm Feb 27 '18 at 01:01 PM

I'm still having an issue with this in 4.18.3. It works with ES3.1, but not ES2.

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

This is a known issue. We just fixed it for 4.18.2.

more ▼

answered Nov 29 '17 at 06:53 PM

avatar image VR-EVO Nov 29 '17 at 06:58 PM

Thanks! When it will be possible to download this new version? We only see 4.18.1. Thanks in advance.

avatar image gmpreussner STAFF Nov 29 '17 at 07:06 PM

Should be pretty soon. Cut-off date for 4.18.2 fixes is today.

avatar image VR-EVO Nov 29 '17 at 07:08 PM

Thanks! :)

avatar image Tosom Dec 03 '17 at 09:26 AM

Same problem for me. When will be ready to download 4.18.2? Thxs

avatar image olim_simon Dec 04 '17 at 01:07 AM

I have downloaded entire UE4 source code from github and adapted modified code which is commented above, but still the bug arises. What can I do more? Mp4 file is normal and playing in Window is OK, but On Android it does not work.

avatar image Tosom Dec 12 '17 at 03:27 PM

Finally 4.18.2 is here but still the same problem. New proyect in 4.18.2, third person & configured for mobile (android). New default level with only 3 planes in scene. I downloaded sample video from link text

and follow the steps for create file media source,media player & media texture, etc and everything works perfect but when I package in ASTC and try to play it, videos are invisible but the sound is working and the most stranger thing is when I shoot the weapon from the third person and the ball (proyectile) hit where the planes would be then I see the plane in red color, no video. What can I do?

avatar image tgraupmann Dec 25 '17 at 08:28 PM

The fix or something related appears to have broken Android Mp4 streaming.

Android MP4 video streaming works in 4.17, but it broke in 4.18.


(comments are locked)
10|2000 characters needed characters left

If you are using a UMG widget to show the mediatexture, please make sure you create a Slate material to sample the media texture and assign it to the widget instead of directly using the mediatexture.

more ▼

answered Jan 08 '18 at 07:23 PM

avatar image

Chris Babcock STAFF
1k 11 110 35

avatar image Erzz May 17 '18 at 05:37 PM

Thank you, this fixed it for me. You may wish to update this tutorial with that step. It worked on PC, but resulted in a black screen on Android before I made this change.

(comments are locked)
10|2000 characters needed characters left

Hi, i have the same issue and i need help plase, im working in a important proyect. It is not work yet on 18.2? i cant fixed it.

more ▼

answered Dec 26 '17 at 07:33 PM

avatar image

1 1

avatar image tgraupmann Dec 26 '17 at 08:58 PM

I just realized that Android MP4 Streaming works in 4.17 but not 4.18.


(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question