x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Random and Confusing Spawning Error in Endless Runner PLEASE HELP

I'm learning UE4 in class for college. We all need to make a project in UE4 and I decided to follow the endless runner tutorial, and then edit it into my own creation. I follow the tutorial and it's working beautifully. I make more tiles and corners (I made about 8 more) and the runner still worked perfectly. Until today.

It was working fine for the first 5 minutes today until I decided to adjust the attach points on two if the new tiles, in order to align the attachments up so the textures blend together (specifically, my Ramp_Down tile). But when I decided to play the game, FOR NO REASON I get a bunch of different tiles spawning INSIDE each other, overlapping and making the game suddenly unplayable. I looked through all of my blueprints and there doesn't seem to be anything that could've caused this. I even exited without saving and reloaded the game (maybe I just did something the engine didn't like when I was messing with the attach points) but even on reloading, the problem persists. And it's ALWAYS on the very first tile that they all overlap. Sometimes the tiles are at right angles, sometimes they spawn below or above, but worst of all, my endless runner is no longer endless. If I "roll the dice" correctly and manage to start a game where the tiles aren't so screwed up they don't prevent me from moving passed the first tile, I get only about 10 tiles in before they just stop. Not the coins though, surprisingly enough. Once I get to the end there are coins where the next tile should be but the tile isn't there.

What I decided to do in order to find out where I went wrong: I went into the RunGameMode blueprint, and changed all of my custom "Floor Tiles" Elements back to the original tiles I followed along with in the tutorial. BP_FloorTile, BP_FloorTile_RampUp, and BP_FloorTile_RampDown for the straights, and BP_FloorTile_LeftCorner and RightCorner for the corners. I run the game and... It actually works great???

I decide to go one at a time and slowly swap out the tutorial tiles for my own until I hit a wall again. Then I'd know what the real problem is. I swapped the normal BP_FloorTile for my "Tile_Straight" and there are no errors so far. Then I decided to change the corners to my custom "Tile_Left" and "Tile_Right." Still no problems whatsoever. I changed RampUp to my own ramp up. Still nothing as you might've guessed.

I, for obvious reasons, want to save my RampDown for last, because I'm pretty sure that's where I went wrong. And so before I do that, I add my extra tiles: one where you must jump or fall off a small cliff onto the next tile: "Tile_Cliff," one where you must jump over an obstacle: "Tile_Jump," and one I made that forces you to swerve through a tight space I call "Tile_Pinch" [NOTE: even though it goes straight, I add this tile as a turn element to avoid it happening too often or multiple times in a row.] So now I have all of my custom tiles active EXCEPT my RampDown. Predictably, there are no problems. It MUST be the RampDown blueprint; I think to myself: "I screwed up the attach points and now the game can't figure out where to put it. But... I didn't save the blueprint when it screwed up, and It wasn't JUST the RampDown tile that was glitching and overlapping the other tiles when the game was screwing up on the first sequential tile." Trying to piece what went wrong in my head, I look over my RampDown blueprint in the Viewport tab. The AttachPoint is on the end, So is the End Trigger. The DefaultSceneRoot is centered at 0,0. Viewing from the top it looks like this: alt text

Not finding a single thing wrong, I sigh and replace the tutorial RampDown with my own in the RunGameMode and...

A B S O L U T E C H A O S

Tiles are spawning all over the place, coins are floating in the air, I randomly died after running into something invisible, every step I took, another tile would spawn somewhere it SHOULD NOT BE.

I recorded a quick 1-minute video of the phenomenon with my phone and uploaded it to youtube HERE: https://youtu.be/Bn_RgdxTvic

I think I'm just going to completely remake the RampDown tile from scratch, because I have NO IDEA why this is happening.

UNRELATED FOLLOW-UP QUESTION

Another thing I'm working on for this game is enemies. I can't get a navmesh big enough for the whole... you know, infinitely generaing map, and while I did hear that one solution is to make it to where your character doesn't move, rather, the map moves around the character, however, I'm way way way too new to this to be able to figure out how to program/ make a change THAT BIG just for the sake of adding enemies, so what do you think about this idea:

Instead of using AI and a NavMesh in order to make enemies, what if I made it to where instead of ACTUAL enemies with AI, I just programmed the enemies like they are projectiles and have them fire once from an invisible source? And could I make them follow the player at a certain speed without relying on a navmesh or AI of any kind?

CAN SOMEONE PLEASE HELP ME WITH ANY OF THIS THE PROJECT IS DUE IN LIKE A WEEK

Product Version: UE older version
Tags:
capturerampdown.jpg (265.1 kB)
more ▼

asked Dec 01 '17 at 01:47 PM in Using UE4

avatar image

Venialia
1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question