x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

ARCore Camera Problem 4.18.1

Hi,

I am currently using 4.18.1 and I have downloaded the ARsample project. I have opened the project and Launched it successfully from the editor onto my Samsung S8 HOWEVER i only see a black screen, my phone is not showing what the camera sees.

I have checked and permissions for the camera and everything else are enabled. Both ARKit and ARCore plugins are enabled Start in AR is enabled Everything is set as default, I have not played with any of the settings.

Is there something else that I might check??

All the best, Dusan

Product Version: UE 4.18
Tags:
more ▼

asked Nov 30 '17 at 06:12 PM in Everything Else

avatar image

maljkovicdusan
21 5 6 10

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Ok, I have been able to figure this out on my own. Apparently it is not enough ti follow the guides from

https://www.youtube.com/watch?v=xi1u287Kyhw&list=PLZlv_N0_O1gZaB0IgQEnO9WOXYRx3Puvo

you also need to follow this: https://developers.google.com/ar/develop/unreal/getting-started

Long story short, it is very important to install arcore-preview.apk as it is not installed to your device by default. You DO NOT need to build the engine from source.

P.S. Chance Ivey if you are reading this, when you make a video I would suggest double checking the information provided is enough to do something from A to Z. You really missed the most crucial part of the thing. Shame.

more ▼

answered Nov 30 '17 at 08:44 PM

avatar image

maljkovicdusan
21 5 6 10

avatar image Burnrate Jan 03 '19 at 07:13 PM

Do you have any updated information on this? I'm using 4.21.

I'm just trying to get the android camera to display on the screen but it isn't working. The preview in the editor works if I set my webcam as the source so I know the material is correct.

I also have the ndk and everything for android running correctly and am targeting API 26 (Oreo 8.0) on an S9. The phone will properly find the cameras and read their names but it won't display anything but a black texture.

It seems the arcore-preview.apk and the second one are several months old already. I tried installing the latest one and have correct permissions and everything but no luck.

Any thoughts or more recent knowledge?

(comments are locked)
10|2000 characters needed characters left

Ok, I have been able to figure this out on my own. Apparently it is not enough ti follow the guides from

https://www.youtube.com/watch?v=xi1u287Kyhw&list=PLZlv_N0_O1gZaB0IgQEnO9WOXYRx3Puvo

you also need to follow this: https://developers.google.com/ar/develop/unreal/getting-started

Long story short, it is very important to install arcore-preview.apk as it is not installed to your device by default. You DO NOT need to build the engine from source.

P.S. Chance Ivey if you are reading this, when you make a video I would suggest double checking the information provided is enough to do something from A to Z. You really missed the most crucial part of the thing. Shame.

more ▼

answered Nov 30 '17 at 08:44 PM

avatar image

maljkovicdusan
21 5 6 10

avatar image EFelder Feb 02 '18 at 05:14 PM

I have ARCore installed on my phone from "arcore-preivew2.apk" but I am still getting the same problem that you described. Anyone has any suggestions to resolve this? Black screen on Galaxy S8.

avatar image geverk Feb 09 '18 at 02:40 AM

I have the same problem

avatar image EFelder Feb 09 '18 at 04:20 PM

Geverk, I have solved this issue. "arcore-preview2.apk" is for UE 4.19+. "arcore-preivew.apk" is for 4.18. Make sure to install one or the other.

avatar image geverk Feb 09 '18 at 06:31 PM

thanks but seems that with 4.18 and "arcore-preivew.apk" i still have the problem (need to check with 4.19) but while i wait for the download i would like to ask you a few stupid things

"arcore-preivew.apk" is the one that when you instal it's named as "tango core"?

when you say a black screen, you mean only black, or you have a big red dot in the middle and some red text alert thta says not available?

thanks

avatar image EFelder Feb 09 '18 at 08:53 PM

Im not 100% sure if arcore-preivew.apk and tango core are the same build.

If I can offer any advice, upgrade to 4.19. It comes with a AR Template and this answered a LOT of questions for me while solving problems. I know the "arcore-preivew2.apk" works for this.

Yes, my problem was a black screen with the red dot in the middle. Another tip I can offer when you upgrade to 4.19, make sure you have a AR Data Asset in your scene, and that your scene executes a "Start ARSession" somewhere in a blueprint. I'm thinking about creating a tutorial on youtube on how to set this up.

avatar image geverk Feb 10 '18 at 02:42 PM

OK thanks a lots for your share your experience!

avatar image irvfpvt Feb 20 '18 at 03:30 AM

Yes, I've been searching through the ARCore docs. I tried the ARSample project with engine ver 18.2 but I also had a black screen with the red dot and debug text messages on the screen, just no pass through camera. I tried the same project with a copy (upgraded to engine 19 pre release), but now I have a black screen, red dot and no messages. I had installed ARCore-Preview2 from the link in another post, so I expected the version 19 engine to work. (This is on a Google Pixel phone - original - which is now running the Oreo version of the OS). When I look at the ARCore version it reports 0.91.171204143 - any ideas?

avatar image geverk Feb 20 '18 at 03:54 AM

you have just update your old project from 4.18 to 4.19? if that the solution is simple, start from 0 using the new handheld ar template from 4.19 preview. (if you have already created something, you will need to adapt to the new version)

avatar image irvfpvt Feb 20 '18 at 06:46 PM

starting from the built in AR project in 4.19 doesn't work on my Google Pixel phone either - red dot over black screen. How do I identify if ARCore is the default vs the preview version? I also installed something called preview 2 from link text
But I'm still having a black screen (no pass through video) in the ARsample

avatar image geverk Feb 21 '18 at 04:35 AM

The point is that you should not use the ARsample, it's obsolete.

so you need in your phone that arcore preview 2. the editor 4.19, open the handheld ar template and test that. That should work.

If that works, you can start to create your project over that template. but forget about the ar sample.

avatar image irvfpvt Feb 21 '18 at 01:29 PM

I did use 4.19 with the template project in 'New Project' but it was hanging up - one of the errors was that it kept saying the phone was offline when it came to deploying the app onto the phone - but I had set the settings as recommended, so that the phone never 'went to sleep' when connected, etc. Also, how do I confirm that AR core is actually preview 2? The version it reports is 0.91.171204143, and ARcore offers the option for 'Uninstall Updates' in order to go back to the default version. This is on the Google Pixel phone (original, purchased a year ago). Thanks for your help!

avatar image irvfpvt Feb 22 '18 at 05:25 PM

I was having problems with the sample project, but 4.19 Preview 5 (with the sample project/template under 'New Project') worked out of the box for me on my Google Pixel phone. Yeah - Unreal team!
For any total AR newbies (I'm only about 3 days ahead of you): firstly - checkout the 'required hardware' for ArCore at Google - if you don't have the right phone turn back link text

1) Install Codeworks link text - and set your project, paths and Android/Apple settings there, accept the license, etc....all as documented (I did this under 4.18.2 but it probably works under 4,19 preview 5 - it's best to make and deploy a default project to make sure it is going all the way to your phone as documented. For this you need to Accept the Android setup on Edit|Project Settings|Android (it should turn from red to green), and Accept SDK License. If you can deploy to your phone (mine is connected over a USB3) breathe a sigh of relief 2) Download 4.19 Preview 5 3) in 4.19, launch the new 'Handheld AR' project, making sure to choose 'mobile' and 'Scalable 2D/3D' 4) Accept the Android setup on Edit|Project Settings|Android (it should turn from red to green), and Accept SDK License again 5) Hopefully the AR project should go right to your phone (mine had to convert about 4000 textures (curious since it is just plopping gray cubes/spheres into the scene for AR...it took about 20 minutes to encode/deploy the first time.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question