x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Animation with disabled Additive Layer Tracks fails to cook

An animation was imported into our project that contained Additive Layer Tracks that weren't needed so the artist disabled the curve in editor. This caused cooking of that asset to result in a UAT error: LogOutputDevice: Error: begin: stack for UAT

LogOutputDevice: Error: === Handled ensure: === [11/30/2017 10:06:25]:
LogOutputDevice: Error: [11/30/2017 10:06:25]: LogOutputDevice: Error: Ensure condition failed: !DoesContainTransformCurves() || (RawAnimationData.Num()==0 || SourceRawAnimationData.Num() != 0) [File:Engine\Source\Runtime\Engine\Private\Animation\AnimSequence.cpp] Line: 379:
LogOutputDevice: Error: [11/30/2017 10:06:25]: LogOutputDevice: Error: Stack: [11/30/2017 10:06:25]:
LogOutputDevice: Error: [Callstack] 0x0000000069C72976 UE4Editor-Core.dll!FWindowsPlatformStackWalk::StackWalkAndDump() [engine\source\runtime\core\private\windows\windowsplatformstackwalk.cpp:200] [11/30/2017 10:06:25]:
LogOutputDevice: Error: [Callstack] 0x0000000069A1123A UE4Editor-Core.dll!FDebug::EnsureFailed() [engine\source\runtime\core\private\misc\assertionmacros.cpp:298] [11/30/2017 10:06:25]:
LogOutputDevice: Error: [Callstack] 0x0000000069A2B906 UE4Editor-Core.dll!FDebug::OptionallyLogFormattedEnsureMessageReturningFalse() [engine\source\runtime\core\private\misc\assertionmacros.cpp:425] [11/30/2017 10:06:25]:
LogOutputDevice: Error: [Callstack] 0x0000000065D3BEBB UE4Editor-Engine.dll!UAnimSequence::PreSave() [engine\source\runtime\engine\private\animation\animsequence.cpp:379] [11/30/2017 10:06:25]:
LogOutputDevice: Error: [Callstack] 0x0000000068661007 UE4Editor-CoreUObject.dll!FPackageExportTagger::TagPackageExports() [engine\source\runtime\coreuobject\private\uobject\savepackage.cpp:2828] [11/30/2017 10:06:25]:
LogOutputDevice: Error: [Callstack] 0x000000006864A586 UE4Editor-CoreUObject.dll!UPackage::Save() [engine\source\runtime\coreuobject\private\uobject\savepackage.cpp:3523] [11/30/2017 10:06:25]:
LogOutputDevice: Error: [Callstack] 0x0000000063DAED3D UE4Editor-UnrealEd.dll!UEditorEngine::Save() [engine\source\editor\unrealed\private\editorengine.cpp:4208] [11/30/2017 10:06:25]:
LogOutputDevice: Error: [Callstack] 0x0000000063C712FE UE4Editor-UnrealEd.dll!UCookOnTheFlyServer::SaveCookedPackage() [engine\source\editor\unrealed\private\cookontheflyserver.cpp:3229] [11/30/2017 10:06:25]:
LogOutputDevice: Error: [Callstack] 0x0000000063C72643 UE4Editor-UnrealEd.dll!UCookOnTheFlyServer::SaveCookedPackages() [engine\source\editor\unrealed\private\cookontheflyserver.cpp:2300] [11/30/2017 10:06:25]:
LogOutputDevice: Error: [Callstack] 0x0000000063C7E587 UE4Editor-UnrealEd.dll!UCookOnTheFlyServer::TickCookOnTheSide() [engine\source\editor\unrealed\private\cookontheflyserver.cpp:1763] [11/30/2017 10:06:25]:
LogOutputDevice: Error: [Callstack] 0x0000000063B17F31 UE4Editor-UnrealEd.dll!UCookCommandlet::CookByTheBook() [engine\source\editor\unrealed\private\commandlets\cookcommandlet.cpp:902] [11/30/2017 10:06:25]:
LogOutputDevice: Error: [Callstack] 0x0000000063B3F561 UE4Editor-UnrealEd.dll!UCookCommandlet::Main() [engine\source\editor\unrealed\private\commandlets\cookcommandlet.cpp:583] [11/30/2017 10:06:25]:
LogOutputDevice: Error: [Callstack] 0x000000006AD2D25F UE4Editor-Cmd.exe!FEngineLoop::PreInit() [engine\source\runtime\launch\private\launchengineloop.cpp:2167] [11/30/2017 10:06:25]:
LogOutputDevice: Error: [Callstack] 0x000000006AD2525A UE4Editor-Cmd.exe!GuardedMain() [engine\source\runtime\launch\private\launch.cpp:127] [11/30/2017 10:06:25]:
LogOutputDevice: Error: [Callstack] 0x000000006AD254AA UE4Editor-Cmd.exe!GuardedMainWrapper() [engine\source\runtime\launch\private\windows\launchwindows.cpp:134] [11/30/2017 10:06:25]:
LogOutputDevice: Error: [Callstack] 0x000000006AD32379 UE4Editor-Cmd.exe!WinMain() [engine\source\runtime\launch\private\windows\launchwindows.cpp:210] [11/30/2017 10:06:25]:
LogOutputDevice: Error: [Callstack] 0x000000006AD33193 UE4Editor-Cmd.exe!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:253] [11/30/2017 10:06:25]:
LogOutputDevice: Error: [Callstack] 0x000000008B3B13D2 KERNEL32.DLL!UnknownFunction [] [11/30/2017 10:06:25]:
LogOutputDevice: Error: [Callstack] 0x000000008BA654E4 ntdll.dll!UnknownFunction [] [11/30/2017 10:06:25]:
LogOutputDevice: Error: [11/30/2017 10:06:25]: LogOutputDevice: Error: end: stack for UAT

The curve data from the source control diff :

RawCurveData=(TransformCurves=((TranslationCurve=(FloatCurves[0]=(Keys=(())),FloatCurves[1]=(Keys=(())),FloatCurves[2]=(Keys=(())),CurveTypeFlags=32765),RotationCurve=(FloatCurves[0]=(Keys=((Value=89.999680))),FloatCurves[1]=(Keys=(())),FloatCurves[2]=(Keys=(()))),ScaleCurve=(FloatCurves[0]=(Keys=((Value=1.000000))),FloatCurves[1]=(Keys=((Value=1.000000))),FloatCurves[2]=(Keys=((Value=1.000000)))),Name=(DisplayName="local_C0_0_jnt"),CurveTypeFlags=100)))

Product Version: UE 4.18
Tags:
more ▼

asked Nov 30 '17 at 07:00 PM in Bug Reports

avatar image

JKimble
6 2 3

avatar image Ridley R ♦♦ STAFF Dec 05 '17 at 09:31 PM

Hi,

Do you also get the same results if you import the animation without the curves? Does this also happen with the curves enabled?

-Thank you

avatar image JKimble Dec 05 '17 at 10:11 PM

If the animation is imported without curves at all, it works fine. If the curves are enabled, works fine.

If the animation is imported without curves, empty curve is added then disabled but not deleted, then it also works fine. We're using FBX 2016/2017 that is included with Maya 2017 Update 4, using the Game FBX Export tool to export.

avatar image uehero Jul 19 '18 at 06:49 PM

I'm struggling with the same problem too, is there a way to fix this? I need the animations to work with their transformed curves.

avatar image JKimble Jul 19 '18 at 07:02 PM

We were experiencing an issue when the animation had been exported with empty curves that were then disabled, but not deleted. As far as I know, given a curve, this works just fine. Or delete the empty curves, don't just disable them.

avatar image uehero Jul 19 '18 at 09:09 PM

Do I do that to all my animations? and how can I delete the empty curves, how can I know if they are empty or not?

avatar image uehero Jul 19 '18 at 09:11 PM

BTW, we are talking about bones transformed in the animations, not the 2d blend animations right?

avatar image Ridley R ♦♦ STAFF Dec 06 '17 at 06:30 PM

Hi,

Thank you for the info. Would it be possible to get a test asset you are experiencing this with as well as your exact repro steps? This will allow me to reproduce the issue on this end and bug it if it is one, as well as find what may be causing it.

-Thank you

avatar image JKimble Dec 06 '17 at 08:43 PM

How would you prefer I deliver the files since it needs to be done privately, according to our Legal Team?

avatar image Ridley R ♦♦ STAFF Dec 07 '17 at 11:24 PM

Hi,

You can send me a stripped down version of the project(any assets that you have having this problem with, etc.) with your repro steps privately here. Once you send it to me, or if you have any questions let me know on this thread and I will take a look at it.

-Thank you

avatar image JKimble Dec 08 '17 at 12:28 AM

Sent a uasset that should be exhibiting the broken behavior on cooking.

avatar image Ridley R ♦♦ STAFF Jan 04 '18 at 06:30 PM

Hi,

I am unable to use the uasset that was sent due to if that is imported alone into the engine(since it is only the animation) the mesh and skeleton are no longer "there". I will need the FBX or the skeleton and mesh uassets with it(These can also be inboxed). I've posted a screenshot below to better illustrate it on my end(excluding the name of the file/details etc.)

-Thank you

[1]: /storage/temp/225909-uassetthumbnail.png

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi,

Due to how long this thread has remained inactive, I will be closing it out for tracking purposes. If you have any other questions or more information regarding the issue, feel free to reopen this thread.

-Thank you

more ▼

answered Jan 09 '18 at 08:51 PM

avatar image

Ridley R ♦♦ STAFF
1.2k 2 4 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question