x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Help: Importing obj with submeshes doesn't work anymore

Hi there,

I know this is a common question, but it did actually use to work for me and suddenly it doesn't anymore. If anyone could quickly help me out with this, I'd be more than grateful. I want to submit my work for a competition and the deadline is soon. :/

In version 4.12.5, with which I started my project, I was able to important one obj mesh with several submeshes. I didn't merge the single meshes in Maya and made sure they all had the same pivot point and aligned in the center. Then I selected all of them and exported them as one file. This worked for 4.12 and I was able to place a tree in my project and assign different textures (material slots) to the submeshes, without having to worry that I accidentally misclick and place the branches far away from the tree trunk.

![alt text][1]

Besides I need this feature, because parts of the tree are animated, but obviously I don't want the entire tree (including trunk) to wobble around.

Now I transferred my project to 4.15. In other projects I noticed that this feature didn't work anymore, whenever I imported objs as I described above it would create several static meshes in my content browser. However, when transferring this project to a later version of unreal, the submeshes remained. I backuped my files, replaced them with new meshes, because I had some changes to make to the mesh, and then reimported the assets (I made sure the files are named the exact same). When I do this, unreal will give me one single mesh without any submeshes and ignores all the other material slots. I tried reimporting my backuped files that did work with the submeshes, and everything went back to normal. I'm confused. Maybe it's not even a problem with the version? But what am I missing? Any ideas?

Product Version: UE 4.15
Tags:
more ▼

asked Dec 01 '17 at 12:35 AM in Using UE4

avatar image

weinrot93
33 2 3 5

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Nevermind. I just found the problem myself. You have to be very careful with naming your meshes in Maya.^^

I named my meshes like that: pine2_base, pine2_branches, pine2_leaves, etc. But when adding more submeshes I typed in the name under shapes, which does not rename the mesh.

I hope this helps other people, who want to use that handy feature. I'm just super glad this still works with the new Unreal versions. :D

alt text

maya-mat.png (455.7 kB)
more ▼

answered Dec 01 '17 at 12:49 AM

avatar image

weinrot93
33 2 3 5

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question