x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Text in VR unreadable. How to fix it?

Hi there,

I want to be able to read from an A4 paper in VR. So I created a mesh with a texture from an A4. The paper mesh is the correct size. However, in VR the text is barely to unreadable because it is blurred, it has a bloom effect, etc. I use an empty VR project. Which settings should I change?

Kind regards,

Product Version: UE 4.18
Tags:
more ▼

asked Dec 01 '17 at 04:00 PM in Rendering

avatar image

ERuts
471 17 25 40

avatar image BeeHive Dec 01 '17 at 10:17 PM

whats the resolution on your texture? :)

avatar image JamesGMarks Feb 15 '18 at 04:04 PM

Hi ERuts, did you ever find an answer to this? Thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Yes I did. It seems that the pixel in the VR headset (Vive) are not enough to make text readable in a real-scale level. If you want text to be readable you have to make it quite large: e.g. 10cm in ue4 units and look from it at a distance of circa 1 meter. We need another generation (e.g. 8k VR sets) for text to be quite readable on a real-life scale such as an A4.

Besides that you need to set the mip gen settings to no mimaps en look arround in your post processing settings: bloom, auto exposure, blurs.

What I also found as an effective method is to play around with the anti-aliasing. There are serveral options which affects small objects with few pixel (like letters). In my case it was most optimal to use no aliasing at all.

more ▼

answered Jul 04 '18 at 11:46 PM

avatar image

ERuts
471 17 25 40

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello,

In your Texture: Try setting Mip Gen Settings to "No Mipmaps"

Bloom can be controlled in your rendering settings, also take a look at Auto Exposure.

Hope that helps!

Alex

more ▼

answered Feb 15 '18 at 08:16 PM

avatar image

Alex O ♦♦ STAFF
2.6k 4 8 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question