x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Green Screen Flashing Bug on Builds

Green Flicker Bug Issue

In UE4.16 and 4.18 (we have modified the engine for our game though)

We have started to see this issue with shipping builds of our game. The screen goes Green and flickers at 60FPS

• Black shows as Green • Yellow shows as Pink. • Only occurs in Fullscreen (but that's the default so the first thing you see). • Visible with or without VSync, although Vsync ON exacerbates the problem.

The issue can be resolved locally by changing from Fullscreen to Windowed. Changing to borderless also solves the problem and means you don't have to play in a window.

However this is a very problematic issue.

Drivers: Latest Windows update Latest Nvidia Drivers (as of Wed 29th Nov 2017)

The DX dialogue is attached.

[1]: /storage/temp/222556-flashing-green-screen-issue.jpg

[2]: /storage/temp/222555-dxdiag.txt

Product Version: UE 4.18
Tags:
more ▼

asked Dec 04 '17 at 06:13 PM in Bug Reports

avatar image

TomHroll7
21 1 1 3

avatar image Highflex Dec 05 '17 at 08:14 PM

Experiencing the same issue with a cooked and shipped 4.18 build of our game. Latest Nvidia Drivers on a 970 GTX.

avatar image Jeff A ♦♦ STAFF Dec 05 '17 at 08:44 PM

Hi Tom,

There are a few simple things I would like you to try first and if these do not work we can dig deeper.

First and foremost, the approved driver for Nvidia 9 and 10 series GPUs is the 388.00 driver. If you could try rolling back to that and see if it solves your problem. Second, could you check and see if Nvidia Shareplay is running if so disable it as this could potentially be causing problems as well. Hopefully this will fix your issue and if not just let me know and we will keep trying. Thank you.

avatar image Roll7tom Jan 29 '18 at 07:51 PM

Hi Jeff, has there been an update from Unreal on this? We are still getting the issue and we did an open Beta this weekend and it is turning a lot of customers away as they assume it's a bug with our game. Games like PUBG can get away with this but this could really destroy our player base.

Is there a patch incoming or a fix in 4.19? Even anything speculative at this stage?

Thanks

Tom

avatar image VSZ May 31 '18 at 06:10 AM

Tom, just checking whether your players are still reporting this issue as well.

For my game I'm still receiving frequent reports from new players about this issue so I'm not sure if the Windows update Nvidia alluded to in this article is out yet.

Another bit of data - For one player the issue flared up after receiving a new Dell update for their Laptop. The issue went away a couple of weeks later with another Dell update - it is unclear whether a Windows update also accompanied these.

In any case would love to hear any data from you or others in a similar situation.

avatar image x27 Dec 21 '17 at 12:30 PM

The same issue here. It started after major Windows 10 update to version 1709.

avatar image Imagine-Games Jan 07 '18 at 02:18 AM

I am getting this as well. I held off on the windows update until about 2 days ago, and the next build I made had this problem. My fix is actually different though, In my graphics options menu in my build, If I set the overall scalability settings to anything, from low to cinematic, the green flicker goes away, and i dont have to touch any of the fullscreen/windowed/fullscreenwindowed settings....

edit* i realized after switching overall scalability that the windowed setting auto changes to full screen windowed and that might be what actually solves the issue... ive gone from 4.16 to .17 to 4.18 and still have this issue... .

avatar image piontek Mar 15 '18 at 03:03 PM

I have the same Issue on packaged project and build with 4.18.

But Its only with fullscreen, not with borderless windowed mode.

And I want to observe, that I'm using a video as main menu background.

Could this has something to do with this issue?

avatar image Solas Jun 28 '18 at 03:12 PM

I have the same problem But only when I work with unreal engine. For example when i render the scene the output video is all green.

avatar image VSZ Sep 16 '18 at 05:33 AM

Just checking whether any others are still receiving reports of this issue from players on the latest engine version(s).

I'm still receiving very frequent reports of this issue from players, so I'm not sure whether Nvidia's explanation of a forthcoming Windows update (which should have reached the public by now) was off.

My game is on an older engine version and for stability can't upgrade without a very rigorous QA cycle, so I'd be really grateful for any information from others with released/beta/EA games where new players are still reporting this issue.

Thank you :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

6 answers: sort voted first
more ▼

answered Dec 21 '17 at 11:13 AM

avatar image

J.C. Smith
56 5 6

avatar image smartyMARTY Feb 14 '18 at 03:51 PM

Reviving because my customers are reporting the issue as well.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have faced the same problem in UE 4.20.3. You may avoid the problem with following option in DefaultEngine.ini file.

[/Script/Engine.RendererSettings]

...

r.DefaultBackBufferPixelFormat=0

The default value is 4 which makes the engine to create default back buffers with PF_R10G10B10A2 format. But I've figured out the format in fullscreen mode is not supported well on some GPUs by testing with DirectX 11 sample program. When I ran BasicHLSL11 sample program with the corresponding pixel format of DXGI, I could see the same situation just like green flickering screen.

I think the reason is not caused by UE though, I wish Epic guys make some modifications to address the problem by changing policies to select default back buffer pixel format.

Here is the testing computer's spec.

  • Operating System: Windows 10 Pro 64-bit (10.0, Build 17763) (17763.rs5_release.180914-1434)

  • Processor: Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz (8 CPUs), ~3.4GHz

  • Memory: 32768MB RAM

  • Card name: NVIDIA GeForce GTX 1060 3GB

  • Current Mode: 2560 x 1080 (32 bit) (60Hz)

  • Display Color Space: DXGI_COLOR_SPACE_RGB_FULL_G22_NONE_P709

I hope this helps you.

more ▼

answered Jan 22 '19 at 04:15 AM

avatar image

xgkick
11 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I am going to mark this as answered due to a lack in response. If you would like to reopen this please reply with more information. Thank you.

more ▼

answered Dec 11 '17 at 02:35 PM

avatar image

Jeff A ♦♦ STAFF
3.1k 2 5 6

avatar image Imagine-Games Jan 07 '18 at 02:21 AM

Jeff, with all due respect to EPIC, this isn't really resolved. You can see the pattern here with all UE4 games from PUBG to Fortnite to our(ue4 community) various development builds...

Just because WE found a solution, it doesn't really make this resolved as the end-user trying out our game for the first time is going to be like - what is this broken piece of software that I just bought?!

*edit, i realize this is mostly MICROSOFT's fault, as the latest update has been causing all kinds of wreckage across various different software/hardware setups... but the problem is still there, and you can't deny that end users are going to get frustrated at the software, not at microsoft or Epic... and we as the devs will suffer... just because there is a hacky workaround it doesn't mean the issue is resolved.. this is going to affect EVERYBODY that makes a new build in this current time until someone fixes this issue (microsoft, nvidia, or epic)...

avatar image Roll7tom Jan 29 '18 at 07:51 PM

Hi Jeff, has there been an update from Unreal on this? We are still getting the issue and we did an open Beta this weekend and it is turning a lot of customers away as they assume it's a bug with our game. Games like PUBG can get away with this but this could really destroy our player base.

Is there a patch incoming or a fix in 4.19? Even anything speculative at this stage?

Thanks

Tom

avatar image Jeff A ♦♦ STAFF Jan 29 '18 at 09:38 PM

Hello,

Have you tried the link posted above by J.C Smith? This has seemed to fix the problem for most people. I have not been able to reproduce this on my end so if you have a way to consistently reproduce the issue please let me know.

Thank you.

avatar image LRitchie Feb 09 '18 at 02:58 AM

Myself and most of my friends are having this issue in every game that has frequent updates on UE4, such as pubg, redout:enhanced edition, squad, foxhole etc. I find it hard to believe you can't replicate it but are there any log/debug files or anything I could send to help?

I think its honestly appalling that we are expected to follow this 'fix' which severely degrades the visual quality by limiting the range of colour, due to an issue solely from UE4,

avatar image VSZ Feb 03 '18 at 04:21 PM

Players on Steam have been intermittently reporting this issue with my game as well. I agree with the comments above that the root cause needs to be addressed :) This forum thread has some hardware data from players (for various games) which may be useful in reproducing the issue.

My game's feedback dashboard concurs with the comments above, that players who encounter this glitch conclude it's an issue with the game; the workaround is posted on my game's discussion board, however most players don't visit the forums, they will simply move on to another game which works for them.

This is concerning for any game trying to grow its player base like others have said above!

It would great if Epic could take a closer look into this. Regardless of where the root-cause stems from, the fact is only UE4 games seem to be affected by this, so please help, Epic! :)

avatar image Jeff A ♦♦ STAFF Feb 09 '18 at 06:53 PM

Hi VSZ,

I need a way to consistently reproduce this on my end in order to go any further with it. Also looking into that Thread that you posted it only looks like it is happening on Nvidia GPUs and only on certain Driver versions. This leads me to believe that it is an issue on Nvidias end not ours. However if you find a way to successfully reproduce this I can bug it.

avatar image VSZ Feb 19 '18 at 07:29 AM

I found an Nvidia knowledge base article which discusses this issue and the workaround. According to that article the issue is with the Windows 10 fall creators update and apparently Microsoft has fixed this issue in a preview build.

I'm not sure whether that preview build is out or not going by the build numbers, though I'm guessing it hasn't as new players are continuing to report it for my game. Will probably need to add some mechanism to make players aware of the workaround, that's the best I can think of until an actual fix arrives. Any other ideas or suggestions are welcome as well!

avatar image GotSomePills Apr 03 '18 at 03:31 PM

Surefire reproduction steps:

Windows 10 machine with any nvidia gpu, multiple monitors, make sure your primary display is NOT your left most monitor or "display 1" and have a shipping build of any project made with UE4.18 that boots to fullscreen.

For some reason 4.18 will never boot to your primary display and will always boot to "display 1" unlike previous versions of the engine, display 1 in fullscreen when it isn't set as your primary display seems to always have the green flashing going on.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Here is how to fix screen flashing issue in Windows 10

  1. Open Task Manager – There are many ways in which you can do that. Method 1- Right click on any blank space in your taskbar and select Task Manager. Method 2- Press Ctrl + Alt + Del. From there select Task Manager.

  2. Click on the File tab. If you are unable to see File tab then click ‘More details’ at bottom left corner.

  3. Select ‘Run new task’.

  4. Type ‘msconfig’ without quotes.

  5. Click on the ‘Services’ tab.

  6. Scroll down and find two services named ‘Problem Reports and Solution Control Panel ‘and ‘Windows Error Reporting Service’. If you have difficulty finding these two services then you click on ‘Service’ column header in the table. This will alphabetically arrange all the services.

  7. Uncheck these two services. Press ‘OK’.

  8. If Windows prompts you to restart the system then restart the system and your problem will be solved.

Source:- https://merabheja.com/how-to-fix-screen-flashing-issue-in-windows-10/

more ▼

answered Mar 22 '18 at 01:42 PM

avatar image

tomjs1
0

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Thanks. I Had the same problem with the GeForce 970 card which started happening after the last windows update.The link from J.C.Smith worked.

more ▼

answered Dec 28 '17 at 08:37 AM

avatar image

LouisRoberts
26 1 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

this has been fixed for me with latest nvidia game ready drivers... win 10/nvidia 980 ti/2 monitors

more ▼

answered May 31 '18 at 01:06 PM

avatar image

Imagine-Games
214 5 10 14

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question