x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging Error with Android Project

Hey guys,

i'm using UE 4.18.1 and want to package my android project. I always get following two errors when packaging the project:

LogTemp: IPP ERROR: Could not find provision directory 'C:\Users\Shadow\AppData\Local/Apple Computer/MobileDevice/Provisioning Profiles/'.

UATHelper: Packaging (Android (ETC2)): ERROR: cmd.exe failed with args /c "F:/CodeWorks/apache-ant-1.8.2/bin/ant.bat" release -Djava.source=1.7 -Djava.target=1.7

I already tried to do following steps but nothing helped:

  • Deleted Saves & Intermediate Folder

  • Updated my Codeworks for Android

  • Reinstalled Codeworks for Android

  • Created new Project and copied the content

  • Checked and Unchecked the "Enable Gradle instead of Ant" in Project Settings

I also attached the log file in case you want to have some detailed information about the packaging process. Thx for the helplink text

Product Version: UE 4.18
Tags:
project.log (587.1 kB)
more ▼

asked Dec 05 '17 at 12:53 PM in Packaging & Deployment

avatar image

SirDavenstein
27 6 10 13

(comments are locked)
10|2000 characters needed characters left

5 answers: sort voted first

OK guys i fixed the problem finally. For anyone who has the same problems, this did the trick (at least for me):

  1. Uninstall UE4.18

  2. Uninstall Codeworks for Android

  3. Delete all the remaining folders of UE4.18 & Codeworks for Android

  4. Reinstall 4.18, make sure to close any projects AND the launcher after installation

  5. Reinstall Codeworks for Android with the installation file which comes with the 4.18 release (Folder: Epic Games\UE_4.18\Engine\Extras\AndroidWorks\Win64) follow the official installation instructions (https://docs.unrealengine.com/latest/INT/Platforms/Android/GettingStarted/1/)

  6. After installation goto this folder: \NVPACK\android-sdk-windows\tools and run "android.bat"

  7. There click on "Deselect All" at the bottom and scroll down to "Extras > Android Support Repository" click on the checkbox and on the install button on the button right, then accept the licenses (THIS IS IMPORTANT) and finish the installation

  8. Open up your project, pack your game for android and it should work now

more ▼

answered Dec 05 '17 at 03:01 PM

avatar image

SirDavenstein
27 6 10 13

avatar image ERuts May 08 '18 at 08:02 PM

Nice tnx, once again a great solution:P Reinstall everything! Worked great.

avatar image 23456agder Mar 20 '19 at 06:51 PM

step 6 I do not understand well, when I execute a terminal opens momentarily, step 7 does not understand well

(comments are locked)
10|2000 characters needed characters left

It's looking for a directory related to iOS? It looks like a configuration problem cuz you shouldn't be using that for an Android package. Hopefully, someone who knows more than I will chime in but in the meantime:

Check your project settings for iOS. If the "Import Provision" is set, try to un-set it. If you can't do it from the editor, try removing the key that is set to the "Apple Computer" path (in the DefaultEngine.ini file in your project/Config directory).

Long shot: you could try turning off the AppleAR plugin. It's enabled in my project and it doesn't affect Windows builds, but it isn't crazy to think it might be affecting Android builds.

more ▼

answered Dec 05 '17 at 01:12 PM

avatar image

Jin_VE
4.3k 31 77 40

avatar image Jin_VE Dec 05 '17 at 01:16 PM

Looks like the project settings is for a provision file, not a directory. UE4 must be picking up that directory setting from somewhere tho. Do you have the iOS dev tools installed?

avatar image SirDavenstein Dec 05 '17 at 01:30 PM

Thx for the quick response. The "Import Provision" is empty in the Project Settings, nothing is set there. In my DefaultEngine.ini is no "Apple Computer" path. And no i don't have the iOS dev tools installed. I also tried to disable the AppleAR plugin and every other plugin related to iOS/Apple but that didn't help.

avatar image Jin_VE Dec 05 '17 at 01:52 PM

I searched the engine's directory tree for "Apple Computer" and the hits that look related to your issue are in the function FIOSTargetSettingsCustomization::OnInstallProvisionClicked() (Engine\Source\Developer\IOS\IOSPlatformEditor\Private\IOSTargetSettingsCustomization.cpp). That looks like what happens when you click the provision button I saw in project settings. It looks like it has something to do with SSH settings. This "IPP Process" is getting run outside of UE4 and it's reporting back that there is an error. I can't say more yet and I'm not even sure that error is why the build fails. But it's at least some help. Maybe somehow the SSH thing is confusing iOS and Android.

Edit: I see this in the log file: "C:\Users\Shadow\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Epic+Games+UE_4.18\UAT_Log.txt for full exception trace". Can you check that log file?

avatar image Jin_VE Dec 05 '17 at 01:59 PM

Just to be thorough: are you sure you have the right Android SDK installed? UE4 is very specific about what you need to do.

avatar image SirDavenstein Dec 05 '17 at 03:02 PM

Thx this helped thinking about a solution for the problem.

(comments are locked)
10|2000 characters needed characters left

Hi host: I am also have this problem with UE4.18.2 packaging android project! And i ues your method to solve this problem,now i can packaging it successful, but"LogTemp: IPP ERROR: Could not find provision directory 'C:\Users\Shadow\AppData\Locaalt textl/Apple Computer/MobileDevice/Provisioning Profiles/'." this log still exist!

If i checked this two option in the pictuer,it will logging this and build field, can you help me?

[2]: /storage/temp/226588-444.jpg

333.jpg (85.8 kB)
444.jpg (115.2 kB)
more ▼

answered Jan 10 '18 at 02:46 PM

avatar image

liebingwang
1

(comments are locked)
10|2000 characters needed characters left

You can try to delete project\build\android folder, and than Project Settings -> Platforms -> Android-> Configure Now

more ▼

answered Dec 12 '18 at 09:34 AM

avatar image

arclee
21 1 4

(comments are locked)
10|2000 characters needed characters left

step 6 I do not understand well, when I execute a terminal opens momentarily, step 7 does not understand well

more ▼

answered Mar 20 '19 at 06:50 PM

avatar image

23456agder
1 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question