x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Set Master Pose is breaking skeleton

I'm trying to create a modular character; one in which I can swap out parts to allow customization.

I got everything into the engine successfully, but when I try using Set Master Pose Component to link the various skeletal meshes into a single character, the skeleton breaks down and mashes up the arms and legs. Example

Here was my approach.

I brought the UE4 mannequin into Maya LT 2018, and split the arms, legs, torso, and head into separate objects. I used Quick Rig to bind them all to a single skeleton.

First I imported everything together as a single character, in order to get the complete base skeleton and physics rig.

Skeleton

Then I imported each object individually as skeletal meshes, each assigned to use the base skeleton and physics rig from the complete character I had first imported.

Then I used a character blueprint to piece all of the objects together into a single character.

Inside the blueprint I set the torso as the base inherited mesh, and added the various limbs as additional skeletal meshes. So far, so good.

But when I try to use Set Master Pose Component to link the limbs to the torso so everything works and animates together as a single character, the skeleton breaks.

Whether I use the construction script or the event graph, once this node runs it all goes to crap, and I have no idea why.

Inside the node I set the head, arms, and legs as the target, and the inherited mesh (torso) as the master.

Node

If it matters, I'm using FBX 2016 format. I tried using 2018 at first, but that caused things to break down before even reaching this stage.

Product Version: UE 4.18
Tags:
more ▼

asked Dec 05 '17 at 04:36 PM in Blueprint Scripting

avatar image

Grimwolf
157 15 18 27

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question