x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Running Setup.command on external drive fails

Hi folks. In order to free up some space I've decided to keep the UE4 source and build files on an external drive. The drive is currently formatted as FAT32 because it stores data for both Mac and Windows.

I'm running MacOs 10.12.6 and Xcode 9.1. My external drive was initially named "LACIE SHARE".

When I run the Setup.command I get the following:

 Registering git hooks... (this will override existing ones!)
 Setting up Mono
 Checking dependencies (excluding Win32, Win64, Android)...
 Updating dependencies:  30% (1/39), 1.2 MiB cached...
 Failed to download 'http://cdn.unrealengine.com/dependencies/3367711-dc3c12a6d6784615ac3c93e5d77a4464/2baf02cd7cefb3dd8f549886b24457f54a7a072f': Sharing violation on path /Volumes/LACIE_SHARE/UnrealEngine/Engine/Source/ThirdParty/Facebook/IOS/DocSets/FacebookAudienceNetworkSDK-4_18-for-iOS.docset/Contents/Resources/docSet.dsidx.incoming (IOException)

I then tried moving all the files over to my local drive and running Setup.command from there. It ran without a hitch so I moved all the files (including the new ones) over to the external drive and then ran GenerateProjectFiles.command. This initially failed because my external drive name had a space in it "LACIE SHARE" so I changed it to "LACIE_SHARE". Building the ShaderCompilerWorker succeeded without any errors. Building UE4 through up a bunch of errors similar to this one:

 fatal error: file '/Volumes/LACIE_SHARE/UnrealEngine/Engine/Source/Runtime/Core/Public/Internationalization/TextLocalizationManager.h' has been modified since the precompiled header '/Volumes/LACIE_SHARE/UnrealEngine/Engine/Intermediate/Build/Mac/UE4Editor/Development/CoreUObject/PCH.CoreUObject.h.gch' was built
 note: please rebuild precompiled header '/Volumes/LACIE_SHARE/UnrealEngine/Engine/Intermediate/Build/Mac/UE4Editor/Development/CoreUObject/PCH.CoreUObject.h.gch'

From what I've read elsewhere these are precompiled when Setup.command is run. So I figured if I went back and ran Setup.command now that I've changed my external drive name it might work but no luck.

So, any idea why I'm getting this "Sharing violation path" error?

Mike

Product Version: UE Github Master branch
Tags:
more ▼

asked Dec 07 '17 at 09:00 AM in Installation & Setup

avatar image

lyndonm
3 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi lyndonm,

The “sharing violation on path” on FAT drives appears to be a known issue with mono and the GitDependencies tool uses mono. See https://bugzilla.xamarin.com/show_bug.cgi?id=38538 and https://bugzilla.xamarin.com/show_bug.cgi?id=44505 for more information. The suggestion is to use a different filesystem as a work around. There are some tools to allow you to write to NTFS drives from macOS and HFS+ from Windows.

For your second issue I would first suggest cleaning the build/intermediate folder and see if that allows the editor to build.

more ▼

answered Dec 09 '17 at 05:03 PM

avatar image

0x414e54 STAFF
66 2 4 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question