x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

InputAxis MotionControllerThumbRightY Axis value always zero when name to long with underscore in the name

Hi, The InputAxis MotionControllerThumbRightY Axis value is always zero when there is an underscore in the name. When the underscore is removed I get my normal Axis value's again. The first Image shows my original test. The second image shows the solution. In the 3th image I tried the underscore on a different place, resulting in also only zero outputs.

UPDATE Shortening the names of the Axis Mappings seems to fix the problem too. In that case there is not a problem with the underscores. Anyway there should be an indication on name-length-limit or something that prevents using underscore in certain cases.

alt text alt text alt text

Product Version: UE 4.18
Tags:
input3.png (26.1 kB)
input4.png (26.8 kB)
thumbstick.png (118.5 kB)
more ▼

asked Dec 07 '17 at 09:39 AM in Bug Reports

avatar image

VlecadGS
51 5 14 21

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello VlecadGS,

I ran a few tests on our end, however I was unable to reproduce the issue that you mentioned. Could you insure that you do not have another event consuming the input from the controller? Could you also check to make sure that the node has been correctly updated after changing the name (removing the old node and re-adding it to the graph)?

more ▼

answered Dec 08 '17 at 02:14 PM

avatar image

Rudy Q ♦♦ STAFF
47.4k 545 132 525

avatar image VlecadGS Dec 11 '17 at 12:14 PM

I thought I removed all the events that might have consumed the input. I did found one that was hiding in the level-blueprint now. So I might have been wrong. I haven't retested evrything yet. I'll try when I'm on more time. Thanks for the reply !

avatar image Rudy Q ♦♦ STAFF Dec 11 '17 at 06:07 PM

I am going to convert my previous comment to an answer for tracking purposes. Feel free to reopen this issue (by posting a reply) if it turns out that this does not resolve the problem and I will be happy to assist you further.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question