x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

VR preview blurry

The default VR motion controller scene is now blurry when viewing in the vr preview mode using the htc Vive. The screen mirror is also blurry. It was fine in previous versions.

Product Version: UE 4.18
Tags:
more ▼

asked Dec 07 '17 at 04:30 PM in Bug Reports

avatar image

hughjohnsmith
13 1 6 5

avatar image radicalappdev Dec 08 '17 at 05:56 PM

I'm seeing the same issue here. This issue is happening with any map I make with VR preview mode in UE4.18 or UE4.18.1

avatar image hughjohnsmith Dec 12 '17 at 09:33 AM

Still the same with 4.18.2

avatar image hughjohnsmith Dec 12 '17 at 12:28 PM

Teste on Windows 10 and 7 and its the same issue.

Setting r.ScreenPercentage = 225 in the level blueprint seemed to fix the issue but this definitely seems like a bug

avatar image darinsmyth Jan 08 '18 at 06:23 PM

Anybody have any solution to this apart from increasing screen percentage? Have tested my vive version and noticed it is much more blurry than the Oculus version in 4.18, 4.16 version was fine for both

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Further testing with old project files has shown that before i was in fact unknowingly using a screen percentage of around 175% (probably set when i started learning UE4 and didn't know what was going on) and so when i went down to 100% in 4.18 ( because the console command hadn't been executed yet) i suddenly noticed the low resolution.

It is strange however just how poor using r.ScreenPercentage = 100 actually is.

Answer is just to use r.ScreenPercentage = 225 if you can and lower if performance suffers

more ▼

answered Dec 12 '17 at 05:22 PM

avatar image

hughjohnsmith
13 1 6 5

avatar image Dalai Dec 20 '17 at 09:06 AM

Surely it should automatically take the resolution from the HMD, rather than you having to manually put in a multiplier in the console.

avatar image hughjohnsmith Dec 20 '17 at 09:18 AM

Yes that would make sense. The thing is though that raising the screen multiplier further still just makes the image better and better but the performance hit is huge.

I'm not quite sure what's going on here, I know super sampling will make an image better as in less aliasing but I didn't expect it to increase the sharpness so much

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question