x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How may I resolve an error "Couldn't find target rules file for target 'ProjectName' when building a project?

Hello, I have just started a new project using Unreal Engine 4.18 with nearly nothing in the project and had added a few C++ files to the project. These C++ files worked well in the previous versions of Unreal Engine. Every time I try to compile them I get the following log message and have no idea how to solve this one. I have found a few other posts on the same subject, but nothing relating to the issue dealing with Unreal it self. Please, will some one help me out with this. Here is a copy of the full log I receive.

ERROR: Couldn't find target rules file for target 'AyselKeep' in rules assembly 'UE4Rules, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.

    Location: C:\Program Files\Epic Games\UE_4.18\Engine\Intermediate\Build\BuildRules\UE4Rules.dll
    Target rules found:
     UE4Editor - C:\Program Files\Epic Games\UE_4.18\Engine\Source\UE4Editor.Target.cs
     UE4Game - C:\Program Files\Epic Games\UE_4.18\Engine\Source\UE4Game.Target.cs
     UnrealHeaderTool - C:\Program Files\Epic Games\UE_4.18\Engine\Source\Programs\UnrealHeaderTool\UnrealHeaderTool.Target.cs
Product Version: UE 4.18
Tags:
more ▼

asked Dec 08 '17 at 03:35 AM in Using UE4

avatar image

tech1187
71 7 16 22

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

In your Source directory, there needs to be a "target" file for each build type you want (that means whether it's building the editor, game, or a server).

If you need an example, you can create a template project and look in that source. The files will be marked *.Target.cs.

If it worked before then those files must not have gotten copied over somehow. If they're gone for good you can recreate them by copying from a template project and renaming the files/classes so they match your project name.

more ▼

answered Dec 08 '17 at 04:11 AM

avatar image

Jin_VE
4.4k 32 77 41

avatar image tech1187 Dec 08 '17 at 07:15 PM

That was very helpful. Thanks for the info, well pleased with your help. :D

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I had this issue when creating projects on one of my computers. For some reason projects created on one of the computers create the following setting in the .uproject file (just open it with a text editor):

"Enterprise": true,

I removed the setting from the .uproject file and now it compiles.
more ▼

answered Aug 19 '18 at 02:57 PM

avatar image

Roel
2.4k 69 42 141

avatar image BigShishi Sep 04 '18 at 02:10 AM

Although I don't know why, it solved my problem perfectly!

avatar image CometGoat Oct 20 '18 at 11:22 AM

This solved it for me too!

avatar image LeFxGuy Nov 20 '18 at 11:13 AM

Fixed it for me, too. Enterprise means that you have Unreal Studio access.

avatar image tech1187 Nov 20 '18 at 12:06 PM

Thank you guys for offering some assistance here. Next issue with this part I am dealing with is, what do I do if there is no "Enterprise": true, located in any part of my codes? So far I have not located this yet even while using the search option to help locate it.

avatar image LeFxGuy Nov 20 '18 at 02:09 PM

this is in the uproject file itself. Which should be quite clear. Just right-click on your uproject and openit with a text editor. Beware that this is not always the correct solution. If you dont have Enterprise = true set, there could still be other problems with your project that lead to failed packages.

avatar image di0deman Dec 12 '18 at 01:49 AM

This solved my problem perfectly! Thank you so much.

avatar image jesusluque Jan 24 '19 at 12:05 PM

yep! solved!

avatar image justin.cook Jan 28 '19 at 02:05 PM
  • for being the solution. I came here from a project started in the SpatialOS branch of UE and back to the main branch. I guess by default they set their projects to Enterprise.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question