x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why my mesh good in preview mode but in game is too dark ?

I model a Iron Man Mark 46 in maya, did all rig, UV, texture in Substance Painter, but when I import to unreal is pretty good in preview mode, but when I put in my project, is getting to darker. And its not only this model, other models have this same problem. Anyone have this kind of problem could help-me ?

alt text alt text

God Bless u all.

Product Version: UE 4.18
Tags:
sem-titulo.jpg (375.6 kB)
sem-titulo2.jpg (338.8 kB)
more ▼

asked Dec 09 '17 at 04:41 PM in Rendering

avatar image

Kurt_C
1 1 2 2

(comments are locked)
10|2000 characters needed characters left

7 answers: sort voted first

This may be obvious but did you try playing with the lighting? Also you can try playing with the game brightness under Lit>Exposure in the view port.

more ▼

answered Dec 09 '17 at 05:10 PM

avatar image

Rymazon
46 6 8 11

avatar image Kurt_C Dec 09 '17 at 06:38 PM

Hello. So, i tried... is the test scene of unreal... but you see the table ? This shadows, materials, look so more good... the lights i think is good, right ?

avatar image Kurt_C Dec 09 '17 at 07:08 PM

Its look like the table have different lights of Iron Man... =/

(comments are locked)
10|2000 characters needed characters left

Go under lighting drop down for the iron man and play with the check boxes there. There should be some lighting options that you can enable or disable.

more ▼

answered Dec 09 '17 at 11:45 PM

avatar image

Rymazon
46 6 8 11

avatar image Kurt_C Dec 10 '17 at 01:50 AM

Hello my friend. I mess with all the options in lighting for Iron Man mesh, but nothing changes... =/

alt text

3.jpg (222.3 kB)
avatar image Rymazon Dec 10 '17 at 10:52 PM

Sorry that is all I have for ideas. I suggest trying the other answer that someone else posted.

(comments are locked)
10|2000 characters needed characters left

Hi!

I'd say it's your material... the other objects don't seam too dark... In the preview window you see your object/character with dynamic lighting!! ..in your scene it's... ? What lights do you have in your scene? Are they statioanry/movable?

more ▼

answered Dec 10 '17 at 03:26 PM

avatar image

Makigirl
1.1k 3 4 8

avatar image Kurt_C Dec 12 '17 at 11:49 AM

Hello my friend. So, the scene it's a basic when you open UE4. I just open a new project and put my model there... and its darker than the preview windows.

avatar image Kurt_C Dec 12 '17 at 01:26 PM

My materials from substance painter. i used the new livelink from UE4 to Substance Painter.

alt text

sem-titulo.jpg (236.5 kB)
avatar image Makigirl Dec 12 '17 at 04:05 PM

Substance's materials (usually?) won't show up the same way in Unreal... maybe it's just me! ;) Have you tried to unplug the ambient occlusion node? That can cause this kind of darkening...

avatar image Kurt_C Dec 12 '17 at 06:38 PM

I unplug now, and still the same darker problem... =/

avatar image Makigirl Dec 12 '17 at 07:44 PM

If you assign a different material to your character (non reflective, bright gray) is it still darker than the other objects in your scene?

avatar image Kurt_C Dec 13 '17 at 11:28 AM

I put the same material of the table in the helmet, and looks good...

alt text

Whats is wrong with my substance painter material ? I put all the nodes in the right place like the substance forum says... =/

sem-titulo.jpg (126.2 kB)
(comments are locked)
10|2000 characters needed characters left

Can you add a chrome material on him? I would suggest that there a missing reflections. Or it is the lightmap. Have you baked your Lighting in the scene? If so, can you increase the lightmap resolution to s.th. like 1024 or so and bake the lighting again? And Maybe add a spotlight to your scene.

more ▼

answered Dec 13 '17 at 11:53 AM

avatar image

Evil_Fischi
282 7 14 18

avatar image Kurt_C Dec 13 '17 at 12:30 PM

Hello Evil_Fischi. My mesh was imported as skeletal mesh and combined all mesh in one. So, how i change the lightmap resolution of that kind of mesh ?

I change the material for the chrome basic that UE4 have from basic material... and its good too... =/

alt text

I used the new plugin "livelink" with substance and UE4, the substance create all material nodes automatic... so, they have to be good, right ?

sem-titulo.jpg (440.1 kB)
avatar image Evil_Fischi Dec 13 '17 at 12:47 PM

When you open the static mesh there you can find the lightmap resolution in the mesh settings.

avatar image Kurt_C Dec 13 '17 at 12:56 PM

My mesh dont have lightmap res... i think skeletal mesh have diferent config...

alt text

sem-titulo.jpg (144.4 kB)
avatar image Evil_Fischi Dec 13 '17 at 01:14 PM

hm, can you disable the normal map in your material?

avatar image Kurt_C Dec 13 '17 at 01:21 PM

I disable... the problem continue... =/

avatar image Evil_Fischi Dec 13 '17 at 01:23 PM

can you import it as a static mesh and check the error is still there? And add a point light infront of the head, I guess that you have too less light.

avatar image Kurt_C Dec 13 '17 at 01:28 PM

I imported, change the lightmap resolution e put a point light... still the same problem... =/

alt text

sem-titulo.jpg (180.6 kB)
avatar image Evil_Fischi Dec 13 '17 at 01:30 PM

can you create a new scene and place your mesh in there? Just a default scene setup, no empty level

avatar image Kurt_C Dec 13 '17 at 01:39 PM

I create a new basic UE4 scene and import my mesh... the table and the helmet look like they are in two diferent light scenes... =/

alt text

sem-titulo.jpg (165.1 kB)
avatar image Evil_Fischi Dec 13 '17 at 01:43 PM

can you add a hdri in the capturereflection actor??

avatar image Kurt_C Dec 14 '17 at 09:49 AM

Hello my friend. I take the same hdri from substance painter and put in the capture reflection actor and its get so much better... but the object will not reflect the surrounding anymore ?

alt text

So, if i make a night scene, the reflection of my Iron Man will be the hdri in cap reflection ? There's a way to prevent that ?

3.jpg (210.5 kB)
avatar image Kurt_C Dec 14 '17 at 09:54 AM

And there's a reflection problem in the point i marked... some blur, i dont know...

alt text

4.jpg (214.1 kB)
avatar image Evil_Fischi Dec 14 '17 at 10:30 AM

I guess that your Unreal scene has too less lights, thats why your meshe seemed to be so dark. If you add more lights and stuff around your charakter and don't use the hdri in your reflection capture actor then it should look as good as in the previewer. Your reflectioncaptureactor is currently only seeing the table, chair and your floor, nothing else, so there are no more information in your reflections. If there would be a complete scene it should look better. Maybe just try out the scenes from the content example project and place him in one of those rooms.

(comments are locked)
10|2000 characters needed characters left

I'd say the material's set with it's own reflection... you can see it's not the environment that is reflecting on the head (last pic)! Maybe there is an hdri image inside your material and it set to too low intensity... try to find it and set it higher OR would be better maybe to have real reflections from the surrounding...

more ▼

answered Dec 13 '17 at 03:25 PM

avatar image

Makigirl
1.1k 3 4 8

avatar image Kurt_C Dec 14 '17 at 09:56 AM

Hello Makigirl, how did i see if there a hdri image inside my material ? I make the textures in substance painter, and use the new plugin that export automatic the textures to ue4 and make the nodes for material... how do i see if there's a image hdri inside ?

avatar image Evil_Fischi Dec 14 '17 at 10:26 AM

hm I never worked with substance but I don't know how it should ever be possible to "bake" a hdr in a texture, or why someone should do it

(comments are locked)
10|2000 characters needed characters left

set your compression settings for OcclusionRoughnessMetalic texture to Masks(no sRGB), then in your material change sampler type for your masks to Masks. Default compression(sRGB) darkens the colors of a texture so it looks correct on the screen, but since masks are just a data you shouldn't use srgb (for example gray roughness would be dark gray with srgb, which then would make your mesh reflect more light).

more ▼

answered Dec 14 '17 at 11:22 AM

avatar image

King Zero
25 1 4

(comments are locked)
10|2000 characters needed characters left

I don' know if you solve this problem, but... I had the same problem in my project with a metal texture from substance painter and I could solve this. The solution was simple change the "Mobility" option of the SkyLight, from "Stationary" to "Movable", and metal textures are rendered pretty good for skeletal meshes. I hope this can be useful for someone! Have a good day,

more ▼

answered Jan 30 '19 at 03:34 AM

avatar image

VGizaL
1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question