x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Making package for Linux

Hi

I'm trying to cook a package for Linux and get the following error:

ERROR: Exception in AutomationTool: No files found to deploy for D:\UE4\UnrealEngine\Engine\Binaries\Linux with wildcard UE4Game and exclusions

The project is just the "blank" project with the two chairs and the table. I've add the extra dependencies for Linux and I've compiled the editor with the development configuration. I can make the win64 packages with no problems.

It looks like the script is having problem finding a lot of assets, so I've tried to remove all the assets from the scene and from the content browser(deleted the files). But the script is still looking for them. This also makes the Win64 packages fail, which is properly another problem.

I've attached the log. Does anyone know what might cause this problem ?

link text

Product Version: Not Selected
Tags:
cook.txt (308.0 kB)
more ▼

asked Jul 23 '14 at 11:23 AM in Packaging & Deployment

avatar image

mbu
31 1 2 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello,

Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes. If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar error, that is not 100% related, could you please submit a new report for it.

Thanks!

more ▼

answered Apr 03 '15 at 07:56 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.8k 292 14 77

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Seems like you are packaging a content-only project, so you need to manually build UE4Game first. We don't ship UE4Game Linux binary by default (perhaps we should), and packaging content-only projects doesn't rebuild binaries by themselves.

You can do that with by building UE4 target in Development (or Shipping, depending on your intended use) configuration for Linux platform, with cross-toolchain supplied (https://wiki.unrealengine.com/Compiling_For_Linux).

Hope this helps.

more ▼

answered Jul 23 '14 at 07:14 PM

avatar image

RCL STAFF
2.7k 59 6 88

avatar image mbu Jul 24 '14 at 07:44 AM

Great. I guess I missed the part about compiling the UE4 for Linux. Now I can build the "blank" project for Linux without problems.

I still get errors when I try to make a package(Win64) for another project, where I've removed some of the standard assets. I've attach the log

cook.txt (176.7 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question