x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Replication: Sever spawns... How to get on Clients?

I'm spawning weapons on a server, attaching them serverside, then instructing the clients to make the same attachments... but nothing.

Alright, So firstly, Running on server:

alt text

Then the server spawns the Weapons:

alt text

Once the weapons are spawned (and look great) on the server for each Character, we tell Clients to attach the Object references for the weapons that the server spawned:

alt text

But in the end... no weapons for either character on the client. Wut's wrong?

Product Version: UE 4.18
Tags:
more ▼

asked Dec 13 '17 at 11:13 PM in Blueprint Scripting

avatar image

Loremage
10 1 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I'm an idiot, I'm an idiot, I'm an idiot,

See in that second image, how the Weapon is spawned with a target Skeletal mesh. That mesh is replicated and gets set up in the construction script (to be fair, really should have worked) but that little bit of construction script wasn't running on the clients (!?). Run with a [Delay0] after [Event Begin Play] on the weapons; no more racing the server lag (I think).

They were always working, I just couldn't see them because, you know, no mesh. That should have been the first thing I checked.

I guess it just took documenting the issue to figure it out (it's been two days q.q)

more ▼

answered Dec 13 '17 at 11:32 PM

avatar image

Loremage
10 1 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question