x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Blender animation import problem - "empty" animations

Hi,

My problem looks as follows: when I try to import animations (.fbx) using a blender, the UE4 imports it as "empty" - that is, after trying to assign it to Skeletal Mesh, Skel mesh disappears.

UE version is 4.18.2 Blender version is 2.79 and i use FBX 7.4 binary

Thanks.

[1]: /storage/temp/224025-ue-import-settings.png

Product Version: UE 4.18
Tags:
more ▼

asked Dec 16 '17 at 03:01 PM in Using UE4

avatar image

TheNoNameGuy
6 1 1 1

avatar image ViceVersa Dec 20 '17 at 03:39 AM

are you sure its empty and not just misplaced? ive noticed with blender when exporting with the FBX 7.4 Binary (from your blender-export-settings picture) the mesh is usually not facing the right direction, or underground, or some other weird issue. when exporting from blender try setting the version to ASCII (i know its version 6.something, i think theres only two options). When you do this, it will be facing the right way, but way too small so also set the scale up to 100.

avatar image AyanMiru Dec 20 '17 at 05:16 AM

Agree with ViceVersa that this might be the issue you have. Little tip if you don't know how to quickly find the mesh inside Animation Asset window. Open Skeleton Tree tab (Window -> Skeleton Tree), select any bone and press "F" to frame to that bone.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

This is messed up. Was bugging be for a while. Turns out all I had to do was rename my character in blender from 'armature' to anything else.

more ▼

answered Dec 30 '17 at 05:39 AM

avatar image

Frank Samsung
56 1 3 4

avatar image staticvoidlol Mar 13 '18 at 07:30 PM

Wow. Thank you so much, solved my issue as well.

avatar image Twerre Mar 19 '18 at 05:21 AM

This solved a headache that I've been working on for a day now, thank you so much!

avatar image Spiris Apr 15 '18 at 12:04 AM

An elegant solution Frank. Thank you
For any engineers looking to remove code that may be impeding their team, in UE4.18.3, you can just comment out the part of FbxMainImport.cpp that searches for the Blender armature bone in FFbxImporter::GetRootSkeleton around line #1680-1690
-Spiris

avatar image such_alonso Aug 28 '18 at 02:37 PM

Thank you! What a ridiculous bug.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question