x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

The Launcher crashes by starting it (MacOS High Sierra)

alt text

Product Version: Epic Games Launcher
Tags:
more ▼

asked Dec 16 '17 at 04:31 PM in Installation & Setup

avatar image

xRuthless_King72
1 1 1 1

avatar image Jacknco Dec 16 '17 at 05:27 PM

I have the same problem since 3 weeks, i'm on win10, and i tried 45 solution the game still don't work.

avatar image Megachris1 Dec 18 '17 at 12:41 AM

I just updated tp Mac OS High Sierra and now Unreal is not opening, anyone have a fix?

avatar image nr59 Dec 19 '17 at 04:07 PM

Me too! high sierra, old project (4.17) crashes on load with UE 4.18.2. Please help! ;-/

avatar image Megachris1 Dec 19 '17 at 10:19 PM

Looks like we are dead in the water to Unreal comes up with a fix. They have to know this is going on and tons of people are locked out of the network.

avatar image Maurisvl Jan 23 '18 at 07:07 PM

I have also the same :(

avatar image Maurisvl Jan 23 '18 at 07:12 PM

This is what I found in the crash report.. He can't read some things.

avatar image Maurisvl Jan 23 '18 at 07:14 PM

Here is the crash report.

avatar image PabloVarela_ Mar 28 '18 at 11:10 AM

same problem. Any solution??

avatar image Megachris1 Mar 28 '18 at 12:09 PM

Good news, I'm back in unreal game engine. It took about 6 to $700 but its working on the Mac Pro. This is the upgrade I did on the mac . new radeon 580 graphics card, added a new hard drive and new ram. The graphics card is a metal type card. Look the upgrade up on youtube.

avatar image Megachris1 Mar 28 '18 at 12:12 PM

This is the fix. New Radeon 580 metal grapgics car, add a new hard drive. You have to get a new monitor because the old one can't fit the new card. And you new new wire's for the card and monitor. Cost $700. Look the upgrade up on youtube.

avatar image Rutze_68 Mar 29 '18 at 12:45 PM

i got the same problem help pls :(

avatar image Megachris1 Mar 29 '18 at 08:10 PM

If you have a Mac Pro desk top you can fix the problem but it cost between $500 to $1000.00 dollars. I did it for $700 and I want to spend another $500 and that turns your Mac Pro to a beast. Look on youtube for upgrading your mac pro desk top.

avatar image Megachris1 Mar 29 '18 at 08:10 PM

If you have a Mac Pro desk top you can fix the problem but it cost between $500 to $1000.00 dollars. I did it for $700 and I want to spend another $500 and that turns your Mac Pro to a beast. Look on youtube for upgrading your mac pro desk top.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

hey! had the same problem and just found a way to fix it. Instead of opening the app, find it in finder instead, right click on it, click show package contents, then go into the "MacOS" folder and open the "EpicGamesLauncher".

more ▼

answered Mar 29 '18 at 08:53 PM

avatar image

indian_princess1
6 1

avatar image INFJwithaNiFe May 30 '18 at 11:18 PM

I wish I could upvote this more than once! IF YOU'RE ON MAC HIGH SIERRA AND THE LAUNCHER CRASHES AFTER INSTALL, TRY THIS. It worked for me too and that was so simple!

avatar image mooseinata Jun 26 '18 at 09:23 AM

I have an iMac and followed these steps but I cannot find the "MacOS" folder. I tried searching, but to no avail. help!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

infjwithanife

I had to rebuild my Mac when this happened. I f you have a Mac pro desktop you can update the Mac, but if you have an old Mac book pro it's over.You need anew computer.

Go to micro center and get a new Metal compatible graphic card. this is the main problem. they have videos on youtube showing how to put them in. You need to also buy wires and you'll need to buy and add a new hard drive or they might call it RAM. when you buy the new graphics card you might need to buy a new monitor because the Mac will not fit the graphics card. This upgrade cost me $700.

Now my problem is adding the SDK. it's to hard on a Mac.

If you have the money buy more memory, you can upgrade from 8 to 64.

more ▼

answered May 30 '18 at 11:45 PM

avatar image

Megachris1
6 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Here's my log

LoginId:1ce2e6585545e939a680589c954b31c3 EpicAccountId:835824c3860b4bc6ac21b2856218e183

SEGV_MAPERR at 0x3

FGenericPlatformMisc::RaiseException(unsigned int) Address = 0x10098799b (filename not found) [in UE4Editor-Core.dylib] FMacErrorOutputDevice::Serialize(wchar_t const*, ELogVerbosity::Type, FName const&) Address = 0x1067d6c19 (filename not found) [in UE4Editor-ApplicationCore.dylib] FOutputDevice::Logf(wchar_t const*, ...) Address = 0x100c35c9d (filename not found) [in UE4Editor-Core.dylib] FDebug::AssertFailed(char const*, char const*, int, wchar_t const*, ...) Address = 0x100babefb (filename not found) [in UE4Editor-Core.dylib] CreateMTLRenderPipeline(FGraphicsPipelineStateInitializer const&, EMetalIndexType) Address = 0x12338aab4 (filename not found) [in UE4Editor-MetalRHI.dylib] FMetalGraphicsPipelineState::FMetalGraphicsPipelineState(FGraphicsPipelineStateInitializer const&) Address = 0x12331e35a (filename not found) [in UE4Editor-MetalRHI.dylib] FMetalDynamicRHI::RHICreateGraphicsPipelineState(FGraphicsPipelineStateInitializer const&) Address = 0x12331e955 (filename not found) [in UE4Editor-MetalRHI.dylib] GetAndOrCreateGraphicsPipelineState(FRHICommandList&, FGraphicsPipelineStateInitializer const&, EApplyRendertargetOption) Address = 0x1064ae391 (filename not found) [in UE4Editor-RHI.dylib] SetGraphicsPipelineState(FRHICommandList&, FGraphicsPipelineStateInitializer const&, EApplyRendertargetOption) Address = 0x1064ad6b8 (filename not found) [in UE4Editor-RHI.dylib] FDeferredShadingSceneRenderer::PreRenderPrePass(FRHICommandListImmediate&) Address = 0x1102a3e30 (filename not found) [in UE4Editor-Renderer.dylib] FDeferredShadingSceneRenderer::RenderPrePass(FRHICommandListImmediate&, TFunctionRef) Address = 0x110294093 (filename not found) [in UE4Editor-Renderer.dylib] FDeferredShadingSceneRenderer::Render(FRHICommandListImmediate&) Address = 0x1102857f8 (filename not found) [in UE4Editor-Renderer.dylib] UpdateSceneCaptureContent_RenderThread(FRHICommandListImmediate&, FSceneRenderer*, FRenderTarget*, FTexture*, FName, FResolveParams const&) Address = 0x11098fc27 (filename not found) [in UE4Editor-Renderer.dylib] TGraphTask >::ExecuteTask(TArray&, ENamedThreads::Type) Address = 0x1109906e4 (filename not found) [in UE4Editor-Renderer.dylib] FNamedTaskThread::ProcessTasksNamedThread(int, bool) Address = 0x1009a3f1c (filename not found) [in UE4Editor-Core.dylib] FNamedTaskThread::ProcessTasksUntilQuit(int) Address = 0x1009a2fc8 (filename not found) [in UE4Editor-Core.dylib] FTaskGraphImplementation::ProcessThreadUntilRequestReturn(ENamedThreads::Type) Address = 0x10099f0ae (filename not found) [in UE4Editor-Core.dylib] RenderingThreadMain(FEvent*) Address = 0x10641c2a1 (filename not found) [in UE4Editor-RenderCore.dylib] FRenderingThread::Run() Address = 0x106430d17 (filename not found) [in UE4Editor-RenderCore.dylib] FRunnableThreadPThread::Run() Address = 0x100a1827e (filename not found) [in UE4Editor-Core.dylib] FRunnableThreadPThread::_ThreadProc(void*) Address = 0x1009c2fc7 (filename not found) [in UE4Editor-Core.dylib] _pthread_body Address = 0x7fff758ae6c1 (filename not found) [in libsystem_pthread.dylib] _pthread_body Address = 0x7fff758ae56d (filename not found) [in libsystem_pthread.dylib] thread_start Address = 0x7fff758adc5d (filename not found) [in libsystem_pthread.dylib]

more ▼

answered Dec 19 '17 at 04:10 PM

avatar image

nr59
31 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question