x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

iOS Mobile Provision missing after import

When I import my mobile provision it will say that a provision already exists alt text

When it I hit okay it will hang on 'Importing Provision' Please wait...alt text

It will then return that No Provisions Found.alt text

My output log will return with this error every time: alt text LogTemp: IPP ERROR: Failed to find embedded plist in .mobileprovision file LogTemp: IPP ERROR: Application exception: System.NullReferenceException: Object reference not set to an instance of an object.

But unfortunately I do not understand what this error means. I've tried following the iOS quickstart tutorial which says it is up to date for ue4 4.18. I have tried doing this in both 4.16 and 4.18 and the results have been the same. I've tried finding answers everywhere but I can't find anything on this.

My attempt today was with a fresh install of 4.18 and a new default project as a blueprint TopDown. I have had no issues at all importing certificates.

I'd appreciate any help with this.

Product Version: UE 4.18
Tags:
more ▼

asked Dec 18 '17 at 04:42 PM in Packaging & Deployment

avatar image

War_and_Donuts
11 2 3

avatar image War_and_Donuts Dec 18 '17 at 10:36 PM

In another forum a user mentioned creating a clean project and copying over Info.plist.

I cannot find this file anywhere. It is not in any of my projects Unreal Projects/(ProjectNameHere)/Build/IOS

It is also not in :\Program Files (x86)\Epic Games\UE_4.18\Engine\Build\IOS\

Could this missing file be my problem?

avatar image War_and_Donuts Jan 04 '18 at 02:44 PM

Just wanted to come back and say I solved this issue.

A project appears to have become corrupted or bugged. Whenever I would import my provisioning profiles they would just be missing. I was also unable to add additional certificates.

I was only able to discover that this was an issue from extensive testing across multiple computers. The same project was consistently causing any of my other mobile setups to break. I would be fine on a new computer with different projects but when I tried to set that one particular project up it would cause this bug across all of my projects. After that, I would no longer be able to deploy anything to my iOS devices.

If you want to test and see if this may be your problem: -If you have another computer attempt to deploy from there with a different project. You will need to go through the whole process of setting up your provisions, and certificates for this new project. -If you can successfully deploy that project, but when you try to deploy your original project and it is still not working- go back and try to get your new project you just made work. Are your provisions missing? Can you deploy anything to iOS on that project that previously worked?

There are a few ways to approach this problem, if THIS is your issue then you'll need to migrate your project's assets and files into a new project. In my scenario I also cleared out all of the old provisions and certificates saved on my computer's user account. When I went to go find these files I had discovered that they were ALL there, but this bug was making them invisible in the editor. If you do not want to clear those old files you can also just work from a different user account on the same computer.

I hope this helps somebody. I got unlucky and this was my first time working with iOS devices on ue4 and it broke the first time. So my initial thinking was that I was making a mistake somewhere.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question