x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cloth collisions still not working in 4.18

Hi I'm aware this thread exists > https://answers.unrealengine.com/questions/667930/clothing-tool-collision-not-working.html

I've made sure none of issues are occurring, but I still can't get cloth collisions to work with my characters clothing. I've tested with the Owen character, and managed to get the cloth to collide there, however when using my animated character imported from houdini with the same settings, I still can't get anything to work.

Any tips would be insanely useful.

Cheers

Product Version: UE 4.18
Tags:
more ▼

asked Dec 19 '17 at 01:24 PM in Using UE4

avatar image

henbull
6 1 2 1

avatar image Gamberana Dec 22 '17 at 08:27 AM

i work with blender, to make colliders work the scaling of the armature of the character must be x=1 y=1 z=1, then i export everything in centimeters (0.01). Theese days i'm experiencing other collisions issues, can you explain better your situation, maybe with some screenshots

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Thanks for the reply. Yeah I'm exporting from Houdini, it is definitely the scaling that's the issue. Usually you have to scale up the model by 100 in Houdini before export, or in the ue4 importer. Scaling in the importer creates an error with an enormously high scale when you apply clothing data. Scaling in houdini leaves the model in Phat's to small to scale capsules properly. That's what I've attached an image of, one image is when I create a body, the other is the smallest I can get it with the scale handles.

I have gotten the cloth to work when applying the scale of 100 in houdini, but then for whatever reason it imports a giant model, that is 100x the original. I just need to figure out how to import the correct scale.

screenshot-41.png (850.4 kB)
screenshot-42.png (975.3 kB)
more ▼

answered Dec 22 '17 at 10:40 PM

avatar image

henbull
6 1 2 1

avatar image Gamberana Dec 24 '17 at 03:04 PM

when you create a physic asset for the character have you tried to lower the minimum bone size to see if you can get the correct scale of the collision? i can't help you on the scaling export settings in houdini because i have never worked with it

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Yeah, doesn't seem to work with changing the minimum bone size. I can get the collisions to work with exporting at 100x scale, then importing at 0.01, but then the skeleton scale doesn't match the mesh and animations are messed up. I think it's going to come down to the exporting settings from Houdini. Thanks for your help though.

more ▼

answered Dec 28 '17 at 11:48 PM

avatar image

henbull
6 1 2 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question