x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Rendering a RenderTarget inside another RenderTarget?

I'm running into an odd issue where a SceneCapture2D(Component) will not render a RenderTarget2D created by the same object and instead opts to draw what looks like drawing a NaN value. The region where the RenderTarget2D should be is simply a copy of what the scene before it was, as if nothing had been drawn at all, but it still draws anything else I put over the actual texture. I've linked a video showing how it looks like below.

How do i solve this issue? I can easily do this in any other engine, but Unreal Engine 4 seems to really dislike having other RenderTargets rendered inside another RenderTarget - I've even seen it straight up reading from another render target for no reason other than that it wanted to.

What I've tried so far is to use a double-buffered RenderTarget, flipping between which one is drawn and captured, and using a capture-and-copy style RenderTarget approach. Both ended up with the same result.

Links

Product Version: UE 4.18
Tags:
more ▼

asked Dec 19 '17 at 04:13 AM in Rendering

avatar image

Xaymar
188 19 26 112

avatar image Davision Apr 11 '18 at 01:43 PM

I was able to do this in UE 4.15 and now I upgraded the project to 4.19 and it is not working anymore. Had you found a workaround for it? If not it would be great if you can submit a bug report, you seem to have it laid out pretty well. This trail effect is what is now broken for me: https://twitter.com/TocoGamescom/status/984060184489283585

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question