x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Landscape blurry/faded out in short distance/range (Even without material) (Texture streaming issue??)

Hello Fellow developers and support.

First off: this is my first question ever asked on the answerhub, since i couldnt find a working fix/answer to my problem.

So here is the problem: My landscape (As you can see is blurry from a short distance with AND without a material).

Here are the things i have tried:

Disable/Enabling texture streaming.

Try to play in standalone mode (Same problem).

Tried ALL of the graphic setting options (Even with console commands).

I tried both Unreal Engine versions: 4.17.2 and 14.18.2 .

I tried also in a new clean project.

I also tried to change the texture to NO mipmaps but then, obviously it gets very weird looking(distorted) in distance which i dont want, cuz it looks ugly.

I honestly think at this point it is a landscape problem (Option that i dont know of), since once again without a material its still blurry/faded out from the short distance.

Any help would be MUCH very much appreciated! :)

Thanks in advance!

Dylan.

Product Version: UE 4.17
Tags:
more ▼

asked Dec 20 '17 at 09:08 PM in Everything Else

avatar image

ShadowDoggie
6 2 5 7

avatar image ShadowDoggie Dec 20 '17 at 09:22 PM

Its just very frustrating, since i have made so much blueprints already that are ready to be implemented in a beautifull landscape/map :(

avatar image ShadowDoggie Dec 21 '17 at 11:27 AM

See this is what i find so weird. Appearantly nobody knows a answer/fix for this problem. Please Some help!!

avatar image ShadowDoggie Dec 21 '17 at 12:12 PM

Just an edit: Changing the streaming pool SIZE doesnt affect the landscape...

avatar image ShadowDoggie Dec 21 '17 at 12:14 PM

Only the sky sphere

avatar image ShadowDoggie Dec 21 '17 at 12:54 PM

Sadly still no answer.. does NOBODY know a fix for this????

avatar image ShadowDoggie Dec 21 '17 at 01:12 PM

Still having the problem!!

problem.png (1.3 MB)
avatar image ShadowDoggie Dec 21 '17 at 01:30 PM

UPDATE: As you can see in the picture it DOES change the pool size (i set it to 30000 poolsize) It just DOESNT update the freaking landscape

edit.png (1.1 MB)
avatar image ShadowDoggie Dec 21 '17 at 01:48 PM

Update: wireframe mode picture (even clearer)

wireframe.png (234.5 kB)
avatar image ShadowDoggie Dec 21 '17 at 02:38 PM

PLEASE HELP!

avatar image ShadowDoggie Dec 21 '17 at 03:17 PM

I find it so weird that nobody knows a fix for this!!

avatar image RealRenders Dec 21 '17 at 08:23 PM

Hi

I cannot see the issue properly in the screencaps. I can think of only two things: 1 The Bluirness is due to the antialising and it is a common and good thing to happen otherwise the amount of graphic info at that distance would create some artifacts. 1. I see you have the atmospheric Fog in the World Outilner. Remember it does some very tinny blurring in long distances.

avatar image ShadowDoggie Dec 21 '17 at 08:36 PM

Deleting the atmospheric fog doesnt do anything. Tried all of the anti aliasing methods including none!

avatar image ShadowDoggie Dec 21 '17 at 08:38 PM

also maybe this picture is more clear..

From the black stripe it starts to fade away

from the red stripe its all faded away

blurry.png (1.2 MB)
avatar image ShadowDoggie Dec 21 '17 at 08:43 PM

I think i have given the most information and the most clear pictures possible.

ALSO when i for example sculpt a mountain then the mountain is not blurry from a distance which is weird..

avatar image ShadowDoggie Dec 21 '17 at 08:59 PM

I HOPE ITS CLEAR NOW

i am so done with this...

avatar image RealRenders Dec 21 '17 at 09:00 PM

alt text

It happens to me as well. I guess has to do with perpendicular lines that´s why the mountain does not have that problem

far-bluirness.jpg (51.0 kB)
avatar image ShadowDoggie Dec 21 '17 at 09:02 PM

Yes you see?

Okay so here is the thing...

I downloaded a map called "landscape mountains" which is a free to download unreal engine map.

and i dont have the problem there.

So i have been comparing all the settings all day and couldnt find the right one :(

avatar image ShadowDoggie Dec 21 '17 at 09:04 PM

The problem is just that i cannot keep developing my game as long as i can't make a landscape without this issue.

avatar image RealRenders Dec 21 '17 at 09:06 PM

The Landscape mountain map has map variations. But lets think how to work it around, if perpendicular lines are a problem, perhaps Normals maps can do a trick there? What about changing the camera FOV?

avatar image ShadowDoggie Dec 21 '17 at 09:10 PM

Normal maps are already in my layer blend (Terrain material) and i tried changing the camera fov but that obviously doesnt change anything since its also happening in the editor without playing. :(

avatar image ShadowDoggie Dec 21 '17 at 09:12 PM

I think at this point we need an expert or unreal engine developer here.

avatar image ShadowDoggie Dec 21 '17 at 09:14 PM

UPDATE!! I just figured something out!

With a static mesh its the same (In this case a cube)alt text

cube.png (1.5 MB)
avatar image RealRenders Dec 21 '17 at 09:15 PM

Well then, how about doing some old-school game tricks? Block the view with objects. Make the player focus on the content which is closer near him rather than looking far. Adding vertical content, even at the distance, can help too.

avatar image ShadowDoggie Dec 21 '17 at 09:16 PM

Are you saying i should use depth of field in a extreme setting?

Cuz i was planning to NOT use depth of field to be honest.

If this is not what youre talking about then i have no clue sorry

avatar image ShadowDoggie Dec 21 '17 at 09:17 PM

O i see what youre saying now...

Well thats what i was thinking.. if i just implement allot of foliage then the ground wouldnt be as visible (Grass for example).

But then again.. sooo much grass would drop the fps insanely, also i dont want grass everywhere.

avatar image ShadowDoggie Dec 21 '17 at 09:19 PM

Also there must be a fix for this right?

I mean in unity i didn't have this problem so i dont get it.

avatar image ShadowDoggie Dec 21 '17 at 09:21 PM

But youre right!! Its only with horizontal objects/ landscapes so far. alt text

alt text

vertical.png (837.5 kB)
horizontal.png (1.2 MB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

5 answers: sort voted first

I am done with unreal engine...

If anyone knows a fix for this landscape stuff please let me know...

Cuz i know SOMEWHERE around there is someone that actually knows the fix.

Dylan

more ▼

answered Dec 21 '17 at 10:45 PM

avatar image

ShadowDoggie
6 2 5 7

avatar image SimSevi Dec 01 '18 at 04:00 PM

It is most likely the mip mapping or the Temporal Anti Aliasing. I have to agree with you it is extremely blurry, try to set nomipmaps for your ground texture.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

What is your target device for packaging? Because in nature there is no such endless plane (except sometimes haha), maybe a low poly forest would do. I ask you this to know how much resoruces you can rely on. Of couse grass is resource-eating (but again, depending on the targeted platform) But perhaps some tall rocks, you can also change the height variation of the ground. Avoid going too planar with the terrain

more ▼

answered Dec 21 '17 at 09:35 PM

avatar image

RealRenders
15 1 4 8

avatar image ShadowDoggie Dec 21 '17 at 09:40 PM

The target is for windows.

I dont know how to post my dxdiag, since the text is to long to post but my hardware is:

Nvidia gtx 1060

ddr 3 16gb

intel i5 6500

What i am trying to make is definitely not a low poly but as high as possible poly.

And yes i tried to make for example: holes in the ground and then it doesnt look ugly from a distance.

But i dont get how for example ark, or pubg does it.

There is no ugliness in the distance of their landscapes.

avatar image ShadowDoggie Dec 21 '17 at 09:44 PM

I am trying to make a open world by the way.

avatar image ShadowDoggie Dec 21 '17 at 09:51 PM

alt text

see? this is not doable i have 14k grass and the fps drops from 120 to 50 ~60

imagine putting the whole landscape with foliage

fpsgrass.png (1.7 MB)
avatar image ShadowDoggie Dec 21 '17 at 10:14 PM

UPDATE !!! I just googled the same problem for a different game engine, not gonna say any name!

And i tried it out with that game engine and it fixed it.

Guess what!!

It had to do with the anisoitropic settings.

Sadly it doesnt change anything to change that setting in the texture in unreal engine.

avatar image ShadowDoggie Dec 21 '17 at 10:16 PM

UPDATE: it does change it but only till a very limited distance...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Try using the TemporalAA. Also try using hair shading mode.

Now about FPS. How big is the texture of your field grass? Are you using LODs?

more ▼

answered Dec 21 '17 at 10:25 PM

avatar image

RealRenders
15 1 4 8

avatar image ShadowDoggie Dec 21 '17 at 10:32 PM

First of all i am already using temporalAA

Secondly i dont know what hair shading mode means/is. i am sorry.

Thirdly i thought i am just gonna make a screenshot of my grass settings.

Cuz yes its using lod's alt text

grass.png (1.8 MB)
avatar image ShadowDoggie Dec 21 '17 at 10:33 PM

O by the way!! my grass is using a 1024 x 1024 texture

avatar image RealRenders Dec 22 '17 at 10:08 PM

In LOD settings change Minimum LODs from 0 to 2. This way, you will reduce resources by keeping the polycount per object low. Also try decreasing your texture size to 512

avatar image ShadowDoggie Dec 23 '17 at 05:05 PM

Hello RealRenders,

Sorry for the late reply.

This is gonna sound very weird but i found out why i found my fps so terrible...

I had a 60 hz monitor today i got a 75 hz and its all fixed!!

Appearantly i see a very big difference in that :D

Next question tho:

As soon as my game is in full screen my fps drops down like a maniac /

avatar image ShadowDoggie Dec 24 '17 at 11:30 AM

Never mind my bad...

Turns out my game wasnt in full screen at all but in windowed.

So here is the thing:

As soon as i have my game in fullscreen--- fullscreenmode 0 it all runs very very smooth.

But.. in fullscreenmode 1 or 2 its terrible.

I created a defaultgameusersettings.ini file and my packaged build is in fullscreen from default now but..... my standalone in the editor is not, and if i add -fullscreen in the additional launch parameters it doesnt set it to fullscreenmode 0 from default...

It even doesnt if i add it in the level blueprint so my question... how do i add it to standalone?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hit alt+enter to enter to Fullscreen in the standalone

more ▼

answered Dec 24 '17 at 01:31 PM

avatar image

RealRenders
15 1 4 8

avatar image ShadowDoggie Dec 24 '17 at 04:47 PM

Ik know that and when i do that its in fullscreen but not in r.fullscreenmode 0 !!!

And only in r.fullscreenmode 0 its a smooth framerate!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Then open the console while in game and write r.fullscreenmode 0

more ▼

answered Dec 24 '17 at 05:17 PM

avatar image

RealRenders
15 1 4 8

avatar image ShadowDoggie Dec 24 '17 at 05:27 PM

Yea i know but the whole problem is that after i do that i need tot press alt enter again tot make IT work (actually change and make IT apply)

What i want is the standalone tot be r.fullscreenmode 0 at default the problem is Just that when i adde the command in the level blueprint thenbit doesnt apply either

avatar image ShadowDoggie Dec 24 '17 at 05:42 PM

Please read ^^

avatar image ShadowDoggie Dec 24 '17 at 06:51 PM

RealRenders?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question