x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

SceneCapture2dComponent renders no reflections

Hi everyone, I occured a "bug?" while I was working with sceneCapture components. The render target texture does not show any reflections from my scene. I have this component in a blueprint that acts as a camera with a display. However I have also a handheld camera blueprint with a display that uses the same workflow. The strange thing is, that the normal cam shows no reflection, the handheld does. I checked every setting in the capture components as well as the texture render targets and they are all equal.

When I use a scene capture2d ACTOR they work as they should. I have also added a new scenecapture component to my cam and this didn't help.

Is there any difference between the actor and the component? Am I missing something?

Greetings

Evil_Fischi

Product Version: UE 4.14
Tags:
more ▼

asked Dec 21 '17 at 10:19 AM in Bug Reports

avatar image

Evil_Fischi
287 8 14 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Ok I fixed it. In my camera actor BP the default scene root was a static mesh that was scaled to 0.2 and was hidden in game. I got rid of the old scene capture component and changed the actual mesh and set the scaling back to 1. Then I added a fresh capture component and connected all the scripts back again. Now everything works....

I don't know what the problem was, but I would guess that it was related to the scaling of the static mesh in the root. Is there anyone from the ue staff that could explaine to me how this could happen?

Cheers ;)

more ▼

answered Dec 21 '17 at 01:21 PM

avatar image

Evil_Fischi
287 8 14 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question