x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Behavior Tree Not Saving

There's something I've been debugging for a while and I just realized that the reason I'm not making any progress is because the behavior tree file is not actually saving. It appears to be saving and if I close the file and open it again in the same instance the changes are there. However, if I close the editor and reopen it, the changes were not made. This is especially odd because my editor does not give me any warnings about unsaved files when I attempt to close it because it thinks it did save the behavior tree file.

The two changes I'm trying to make are 1. Remove an unused variable from the Blackboard 2. Change a variable in a service so that TargetLocation points to TargetLocation instead of TargetLocation pointing to TargetFollow

When I make these changes and run I can see from breakpoints that the key is still referencing TargetFollower instead of TargetLocation meaning that in runtime (or if I close and reopen) it is not using my changes.

edit: I forgot to mention, I've tried using save all instead of just saving the behavior tree. It still doesn't actually save.

Product Version: UE 4.18
Tags:
more ▼

asked Dec 21 '17 at 05:49 PM in Blueprint Scripting

avatar image

CalamityDev
6 1

avatar image AlteredCreation May 01 '18 at 08:35 PM

I am having this issue on UE 4.19.1 as well, i have tried it on a different computer, tried all different types of saves, anything I do reverts after I close UE. Did you ever find a solution?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Yes. I had a mistake with the blueprint. I can't remember exactly what it was but it was something stupid. The blueprint was not saving because there was an error even though it wouldn't notify me that there was anything wrong. Double check that you don't have an obvious error.

more ▼

answered May 04 '18 at 12:34 AM

avatar image

CalamityDev
6 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question