x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

memory references

I am trying to delete an animation blueprint but the editor tells me there are still 2 memory references. I can't find out what the memory references are and the only option is Force Delete.

Here's a list of what I've tried so far:

  • detach animation blueprint from my character blueprint so it's not using it anymore (Use Animation Blueprint: None) and then compile/save

  • "Select Actors Using This Asset" which tells me "No Actors Found."

  • Gone to Reference Viewer (image attached) and then right clicked the animation blueprint (on the left in the attached image) and selected "Show Referencing Objects List" but it doesn't show any results

  • Closed the editor and restarted

If there are 2 memory references shouldn't the "Show Referencing Objects List" show what they are? How can I find the memory references so I don't have to force delete?

alt text

Product Version: UE 4.18
Tags:
referenced.png (328.9 kB)
more ▼

asked Dec 21 '17 at 06:44 PM in Using UE4

avatar image

jr557
48 10 12 19

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey there, i get a similar problem sometimes when i had an asset selected as the default value for a certain variable and then i remove the variable. Have you tried closing the engine, deleting the asset (or move it away) and start the engine again to see if he really misses the asset?

more ▼

answered Dec 21 '17 at 06:52 PM

avatar image

xlar8or
6k 160 129 304

avatar image jr557 Dec 21 '17 at 07:11 PM

I manually moved the animation blueprint out of my project directory and restarted the editor. It doesn't show up in the content browser anymore and I don't see any errors. It looks like it worked, but feels kind of hacky going around the editor and manually moving files in the project directory. Is this a known bug with the editor?

avatar image xlar8or Dec 21 '17 at 07:20 PM

Usually you should try to right click on the content folder and click Fix up redirectors to try to remove pending stuff the engine leaves behind. It's not that unusual to go outside the editor, unreal engine spawns a lot of 1kb files and you have to manually delete them, because they dont show up in the editor. If deleting the asset manually worked please mark the answer as correct and upvote it if you found it helpful :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question