x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

4.18.2 Daydream Google VR Laser Component for Google VR Motion Controller Not Working

I have not been able to get the laser and/or reticle to show up in any project (blank, third person, and documentation example project - all BP projects). I have been able to get all the buttons to the controller to work and the controller itself is visible with correct location and rotation. The Laser and reticle are just missing. Any thoughts or help would be appreciated.

alt text

Details:

Engine Version: 4.18.2;

Android Device: Pixel 2 XL running Android 8.1.0;

Headset:Daydream View 2017;

Target hardware: Mobile/Tablet, Scalable 3D or 2D;

Plugins: Google VR v 1.7(GVR NDK v1.80.0), Google VR Motion Controller v 1.7(GVR NDK v1.80.0);

SDK license accepted in APK Packaging;

Project configured for Android;

Configure GoogleVR to support... Tried all possible array combinations of Daydream 3.3 dof, 6.3 dof, and cardboard Project configured for Goolge Play services;

Min and Target SDK versions both at:24;

Gradle enabled;

Support arm64 [aka arm64-v8a];

Support OpenGL ES2;

Moblie HDR disabled;

Android SDK see screen shot installed via codeworks: alt text

I attempted to use the 'Official Google Daydream Unreal' link from Unreal's documentation for addtional assistance (https://developers.google.com/vr/unreal/), but I got this page cannot be found starting about 4 days ago. This link was working last week. The Unreal specific controller mapping page is also missing off of google's site. Also missing - https://developers.google.com/vr/develop/unreal/daydream-in-unreal alt text

From Unreal's documentaion followed steps on Set Up Motion Controller for Google Daydream VR(including all prerequistes from Google VR Quick Start and Set Up Cameras for GoogleVR documentation): https://docs.unrealengine.com/latest/INT/Platforms/GoogleVR/HowTo/MotionController/index.html

Video on this page (seen here: https://youtu.be/7728npwW1fQ) shows a what appears to be the laser reticle moving in sync with the motion controller

I tried the example project from the link on this page (GoogleVR Motion Controller Example Project: (https://epicgames.box.com/s/ya3fk0zs57ur49npm21ligcgxcve1g6j) loaded the project in 4.18 and deployed to my Pixel 2 XL and the laser component visable in the video was not there. I only get the controller itself just like in the blank and third person test projects I created. The pawn blueprint in the example project is set up exactly the way it is in my project.

From a bit of googlefu I found that I should be able to access the laser from the Google VR Motion Controller, but I can only find Get Laser Material, and Get/Set Laser Visual Component Tag.

I've also tried working with the Google VR Laser Visual Component directly in the pawn blueprint, but I could not get it to work or even attach to the motion controller when deployed. alt text

Thank you!

Product Version: UE 4.18
Tags:
more ▼

asked Dec 21 '17 at 11:32 PM in VR

avatar image

Mayrin575
8 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It is not documented anywhere that I know of but the new google SDK in 4.18 does the ray differently.

You need to use the new "Google VRLaser Visual" component:

alt text

place a TAG on it. Then copy the TAG name into the motioncontroller component in this field "Laser Visual Component Tag":

alt text

(even though the tooltip text says component name this must be the TAG ;) ).

more ▼

answered Dec 29 '17 at 09:36 AM

avatar image

aussieburger
1.5k 43 176 75

avatar image Mayrin575 Dec 29 '17 at 08:18 PM

I played around with the Laser Visual Component Tag field before, but I put the GoogleVRLaserVisual Component name in instead. After reading this I went back and found the Component Tags array in the GoogleVRLaserVisual Component added a value and made that Laser Visual Component Tag in the motion controller match and it worked. Thank you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question