x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Root motion not working in preview`

I have a character that swings a sword and steps forward as they do so, I'm intending to use root motion to get this to work.

Root motion is enabled for the swing animation in persona and the character stands in place when swinging (when I process root motion the character begins to walk forward. People have mentioned there should be a red line but I don't have one (though I don't know if I need to enable visualization or something)

The animation is being played through a montage in the animation blueprint and root motion is enabled for montages, when previewing the game though the character isn't translated at all (the capsule remains stationary).

I've loaded the project into UE 4.18 and it still doesn't work, the only thing I can think of is that I need to rename the root bone to "root" (as it's named 'charactername_reference' at the moment b/c that's what Maya's human IK defaulted to) or that it's possible because the root joint in maya isn't a normal bone (again, it's the thing human IK defaults to) - but then I wouldn't know why it would work in persona at all...

there's very little information about this problem and the only other forum post I could find was archived w/o an answer so any help would be extremely appreciated!

I can post a video if I didn't explain the situation well

edit: https://youtu.be/pUHx_MrJuKw annotated video of the problem

Product Version: UE 4.16
Tags:
more ▼

asked Dec 22 '17 at 04:39 PM in Using UE4

avatar image

theitoproject
6 1 4 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Okay I got it working!!!!! When I first made this character (which was right as I began learning unreal) I had added another component in the blueprint for the skeletal mesh and had left a slot called Mesh (inherited) empty, I replaced all the skeletal mesh references in the BP to the Mesh (inherited one) and set up the character in there (added the skeletal mesh, the anim blueprint, etc) and it works now! Thanks for all the help bro, very much appreciated :)alt text

characterbp.jpg (291.1 kB)
more ▼

answered Dec 24 '17 at 04:30 PM

avatar image

theitoproject
6 1 4 4

avatar image xlar8or Dec 24 '17 at 04:45 PM

Good to know :) Please mark the answer as correct to close it !

avatar image 123marinija Apr 24 '19 at 08:18 AM

Thank you! It works!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey there, a video would be helpful. You say that in preview in doesnt work, but what about in runtime?

more ▼

answered Dec 23 '17 at 12:13 AM

avatar image

xlar8or
6k 162 129 305

avatar image theitoproject Dec 23 '17 at 05:10 AM

okay, I added a video in the original post, I'm still quite new with unreal so if there's anything I missed please tell me!

avatar image xlar8or Dec 23 '17 at 11:09 AM

To see the red line you need to go into Show > Bones > All Hierarchy. The preview seems fine once you enable root motion and process root motion, he starts walking forward and accumulating the movement. Is the problem when you play the game?

avatar image theitoproject Dec 23 '17 at 01:18 PM

Yeah, it's only in game (I show it at the end of the video) It just seems like the capsule component isn't moving - someone said if the skeletal mesh is too small root motion doesn't work but my mesh is about half the size as the third person example thingy (the mannequin guy)

avatar image xlar8or Dec 23 '17 at 01:23 PM

Do you have the Root Motion mode in the animblueprint to Root Motion from montages only, and do you use the animmontage slot in the animation graph?

avatar image theitoproject Dec 23 '17 at 05:49 PM

Yep, root motion is from montages only and the anim montage slot is being used in the anim graph

avatar image xlar8or Dec 23 '17 at 09:13 PM

Can you show me the animation graph and play animmontage code?

avatar image theitoproject Dec 24 '17 at 09:24 AM

The event calling the anim montage is just a button press and the slot the swinging montages are in is the "default slot" (which is the final thing in the anim graph chain) alt text

animgraph-rm.jpg (248.6 kB)
eventgraph-rm.jpg (241.1 kB)
avatar image xlar8or Dec 24 '17 at 10:51 AM

Can you try playing the animmontage on the character? Make a key bind and execute the montage play and see if that makes a difference.

avatar image theitoproject Dec 24 '17 at 03:55 PM

activating the montage through the character BP instead of the anim BP still doesn't work (unless you meant something else..?) Because the character moves in the preview window in persona I think the problem is that the capsule isn't properly connected to the skeletal mesh or something

avatar image xlar8or Dec 24 '17 at 04:02 PM

I was talking in gameplay, not in persona preview. Bind a key to the play animation montage and see if that works. can you show me the animation graph?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question