x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

"Buffer Visualization" > "Custom Stencil" does not animate properly, is not readable [on mac] [mostly fixed in High Sierra]

I am testing on Mac OS X 10.12.6 (16G29) with Unreal Version: 4.18.2-3794801+++UE4+Release-4.18. The editor seems to run with Metal when it runs. I am using a Retina macbook. I have not tested on Windows.

SETUP
I am trying to follow this third party tutorial http://www.tomlooman.com/multi-color-outline-post-process-in-unreal-engine-4/ . It at one point shows an attractive image of a "Buffer visualization" for "custom stencil" mode: https://i2.wp.com/www.tomlooman.com/wp-content/uploads/2015/10/ue4_coloredoutlines03.jpg?w=900

I have a project (I can provide a sample project) where I have set Project Settings -> Postprocessing -> Custom Depth Stencil Pass to "Enabled with Stencil". I have created two cubes and checked "Custom RenderDepth" in both. "Custom Depth Stencil Write Mask" is set to "Default" and "CustomDepth Stencil Value" is set to 1 for one cube and 2 for the other cube.

Here are the cubes:

alt text

OBSERVED BEHAVIOR
If I go to the "Lit" menu , and choose "Buffer Visualization", then "Custom Stencil", I see only blackness.

If I then go to the menu, choose "Buffer Visualization", then "Custom Depth", I get some gray cubes that look plausibly like a visualization of the depth buffer of the two cubes. I can in this visualization use normal actions to move the camera such as click-dragging or option-click-dragging, if I select items in the World Outliner they are highlighted in the viewport, and if I delete an item in the World Outliner it disappears from the viewport.

alt text

If I go back to the menu, choose "Buffer Visualization", then "Custom Stencil", I get this:

alt text

First off, notice that this text is illegible. Whereas the screenshot from the tutorial above has nice legible block text, I get a slightly garbled but readable "255" on the left cube and on the right cube I cannot guess what number this is meant to be. Maybe this is a mac retina thing?

Second off, if I at this point perform camera movement such as click-dragging or option-click-dragging, nothing happens. I can select items in the world outliner or even delete them and nothing changes on screen. The viewport is simply not animating. If I switch back to "Lit" and move the camera around, then go back to "Custom Stencil", I see the same frozen view of the two cubes above I last saw. The only way to get the "Custom Stencil" view to update is to switch first to Custom Depth and then switch to Custom Stencil. Custom Stencil will always show the scene with the content and camera angle of the most recently rendered Custom Depth frame.

EXPECTED BEHAVIOR

The text in the "Custom Stencil" buffer visualization should be readable. This is most important.

The "Custom Stencil" mode should animate and update and allow selection of objects the same way that the "Custom Depth" mode does.

If I have misconfigured my project somehow and this is why "Custom Stencil" is misbehaving, the "Custom Stencil" mode should show an error rather than illegible numbers.

The text in Mac Retina mode is also (in addition to being pixel junk) very small; if this is possible, it would be nice if it could be the same size as it is in the screenshots in the Tom Looman tutorial.

Product Version: UE 4.18
Tags:
more ▼

asked Dec 24 '17 at 12:35 AM in Bug Reports

avatar image

mcclure111
86 4 8 15

avatar image mcclure111 Dec 24 '17 at 10:17 PM

Update: I tried this on Windows 10 version 1709 on a windows laptop. Everything looked and worked great.

If this helps pinpoint anything, my Windows test machine lists its video card[s] as "Intel(R) HD Graphics 630" and "NVIDIA GeForce GTX 1060". My mac test machine lists its graphics as "Intel Iris Graphics 6100 1536 MB". The windows machine is using 1.75 display scaling.

If there are some features that do not work on mac/metal or do not work on certain video cards this is understandable but this needs to be documented and Unreal should display a useful error instead of pixel garbage.

Windows 10 screenshot of above project:

alt text

cubes.png (111.6 kB)
avatar image mcclure111 Dec 25 '17 at 11:43 PM

I filed a related bug that SceneTexture:CustomStencil does not work, again on mac only. https://answers.unrealengine.com/questions/740168/scenetexturecustomstencil-emits-only-zeroes-on-418.html

avatar image mcclure111 Jan 05 '18 at 05:02 AM

Another update: Upgraded mac to High Sierra 10.13.2 (17C88). Animation problem is fixed. Legibility problem is **seriously improved but still inferior to Windows. A screenshot is attached. it is legible now but is defs harder to read than on Windows. I am unblocked but I recommend trying to improve the legibility.

alt text

avatar image sytelus Dec 29 '17 at 01:43 AM

This is causing issue in AirSim as well. Related bug: https://github.com/Microsoft/AirSim/issues/702

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question