x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cannot open source file name.generated.h

Hey guys, I have a problem with my UE4 project, every time I want to compile I get an error which says that the generated.h class of every class of mine cannot be opened. And yes I tried this: Rightclick on .uproject and Generate VS project files but nothing changed.

alt text

Product Version: UE 4.18
Tags:
screenshot-49.png (28.8 kB)
more ▼

asked Dec 28 '17 at 08:42 PM in C++ Programming

avatar image

MrZelektronz
47 5 9 16

avatar image RosProPlays Sep 03 '18 at 02:58 PM

Hello i ve the same problem, but when i lucked to rebild the projec it says the project cannot be compiled try to rebuild it maually from source. How to do it?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hi,

You need to do a little more than just regenerating VS project files. Close both the Unreal Editor and Visual Studio. Open your project directory and delete all these folders - .vs, Binaries, Intermediate, Saved [optional], and also YourGame.sln files. Make sure that the Config folder is there and that you do NOT accidentally delete it!

Next, right click on the YourGame.urpoject and select Generate Visual Studio project files. Open the .uproject file once it finishes regenerating. The Editor will prompt you with a missing .dll module again and will ask you to rebuild the solution. Click Yes and it will start rebuilding. It should now successfully compile if there are no bugs in your code.

Hope this helps :-)

more ▼

answered Dec 28 '17 at 09:04 PM

avatar image

Vizgin
1.5k 10 10 17

avatar image MrZelektronz Dec 28 '17 at 09:19 PM

Thank you :D It worked ^^ Well, I needed to rebuild it manually because of some minor coding errors but then it worked

avatar image Vizgin Dec 28 '17 at 09:22 PM

You're welcome :-) Please consider marking the question as "resolved" to help us better filter unanswered questions. Thanks.

avatar image MrZelektronz Dec 28 '17 at 09:24 PM

Well but now every time I wanna start the project the editor crashes without any error message

avatar image Vizgin Dec 28 '17 at 09:26 PM

It's probably because of null accessing somewhere in your code. Please refer to my other answer here where I provide some guidelines and tips on how to address these types of errors.

avatar image MrZelektronz Dec 28 '17 at 09:46 PM

Thank you for that advice but this is not the case :/ There must be another reason for it to crash

avatar image Vizgin Dec 28 '17 at 10:06 PM

If you cannot debug please provide more information (preferably with pictures) of the errors you're getting and post them either here if they're relevant or as a new question.

avatar image Chris Payne Kuju Jan 14 '19 at 08:58 PM

This made no difference to my project, and because it's a nuke-the-site-from-orbit solution, provides no insight as to what the actual problem is.

avatar image RoosterFather Jan 24 '19 at 10:34 PM

Ok now, my project have error when rebuild and doesnt open at all.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This looks more like the 4.20 bug that does not provide the correct includes. just add the full path to ProjectName/Intermediate/Build/PLATFORM/UE4Editor/Inc/ProjectName before any generated.h file and you should be good to go

more ▼

answered Sep 04 '18 at 04:40 AM

avatar image

TheDreamCatcher
258 2 4 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Seems like a bug with visual studio,all I did was rightclick->Open Document and then it started compiling normally for me.

more ▼

answered Oct 27 '18 at 07:19 PM

avatar image

hi i solo carry
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question