Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to set the Visual Studio version?

Hi, I have VS2015 and VS2017 installed but Unreal 4.18 generates always only VS2015 solution files. Visual Studio 2017 got installed first and I installed Visual Studio 2015 later to open an old Unreal 4.13 project.

How can I select the Visual Studio version I want to work with?


Product Version: UE 4.18
more ▼

asked Dec 30 '17 at 05:32 AM in Installation & Setup

avatar image

36 2 3 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

So... apparently there is an ENGINE setting (under Edit->Editor Preferences) as well as a PROJECT setting for this. Changing the PROJECT setting then rebuilding the Visual Studio project only did not work for me until I also changed the ENGINE setting. The engine setting is under the "Source Code" section.

more ▼

answered Feb 16 '18 at 05:32 PM

avatar image

427 20 96 123

avatar image Sandstorm84 Mar 29 '18 at 09:18 AM

To Disambiguate: He's talking about the engine settings under Edit -> Editor preferences -> General -> Source code

Reason I comment this is that I was looking for a source code area under the Engine tab, in the PROJECT settings - which didn't exist :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Go to Edit->Project Settings-> Platforms-> Windows -> Toolchain ->CompilerVersion. You can switch between Visual Studio 2015 or 2017.

more ▼

answered Dec 30 '17 at 06:22 AM

avatar image

250 10 5 15

avatar image Takatu Dec 30 '17 at 06:24 AM

Thanks. That is exactly what I'm looking for. I must have overseen it when I checked the settings. ... But it seems to have no effect. I have now VS2017 set as compiler but Unreal still generates VS2015 solution files.

avatar image Mellnik Dec 31 '17 at 12:56 PM

Got the same problem, selected VS2017 but still opens 2015.

avatar image NMouzourakis Jan 12 '18 at 08:03 PM

Hi, I'm having the same issue on 4.18.2. Is this a known issue yet?

avatar image janimationd Feb 15 '18 at 11:16 PM

I'm also having this issue, changing the setting to 2017 in a fresh project then adding my first C++ class sets the compiler version to 2015.

avatar image masmil1988 Jan 16 '19 at 03:42 PM

You should change the editor in Edit > Editor Preferences > General > Source Code > Source Code Editor

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I had to change both the Engine and Project preference settings as stated in other comments. Then completely close out of my game project (i.e. close UE4 completely). Then "Regenerate project files" (or whatever that's called I forget) in the project folder on the disk. After generating project files, then I was able to reopen my game project in UE4 and Unreal finally started using Visual Studio 2017 for me (instead of 2015)!

more ▼

answered Apr 13 '19 at 09:43 PM

avatar image

76 3 8 13

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

There is no need to compile the editor just to change the compiler setting. In your project directory update the following files:

File: Config/DefaultEngine.ini


File: Config/DefaultEditorPerProjectUserSettings.ini


That should let you compile with your chosen version of visual studio instead of doing it twice.

more ▼

answered Jun 07 '19 at 01:31 AM

avatar image

67 4 7 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question