x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

iOS LAUNCH FAILED. HELP!!!

I can't launch my app on my iPhone 7. Everything was working fine on my iOS launch until yesterday. I'm not sure why but I keep on getting the same error. I tried creating a new app id and a new mobile provision.

 LogPlayLevel: DeploymentServer: [DD]  ... Error: Failed to connect to bundle 'com.mygame.'
 LogPlayLevel: env:    2   DTDeviceKitBase                     0x000000011a21f441 -[DTDKMobileDeviceToken mountDeveloperDiskImage:withError:] + 782  
 LogPlayLevel: env:    3   DTDeviceKitBase                     0x000000011a21fcf8 -[DTDKMobileDeviceToken mountDeveloperDiskImageWithError:] + 488  
 LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: CodeSign Failed
 LogPlayLevel: RunUAT ERROR: AutomationTool was unable to run successfully.
 PackagingResults: Error: Launch failed! Failed to Code Sign

I tried installing the latest xcode (9).

I'm using a MacBook Pro.

I have UE4 4.17.2.

I'm uploading my output log here. ----> link text

I'm also uploading a screen shot of the iOS settings. ----> alt text

I would really really appreciate any help.

Thanks

Product Version: UE 4.17
Tags:
iossettings.png (100.4 kB)
outputlog.txt (35.8 kB)
more ▼

asked Dec 30 '17 at 11:41 PM in Packaging & Deployment

avatar image

bariscavusoglu
11 2 6 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Barış,

The identifier you create in the Apple Developer Panel looks different than the identifier you enter in Unreal Editor Settings. I think the problem is related to that.

Can you check?

more ▼

answered Dec 31 '17 at 09:35 AM

avatar image

Sertac Ogan
1.5k 30 11 46

avatar image bariscavusoglu Dec 31 '17 at 09:59 AM

Hi Sertaç, Thanks for your reply.

I don't get what you mean by the identifier that I create in Apple Developer Panel?

I'm sending you the app id section of ' com.mygame.* '

alt text

avatar image Sertac Ogan Dec 31 '17 at 10:18 AM

Okay then. Can you change bundle identifier com.mygame.test instead of com.mygame. on Project Settings?

avatar image bariscavusoglu Dec 31 '17 at 10:14 AM

Also I found a forum thread link text

Here, user Satra18 states that the bundle ID needs to have a real website domain.

So I bought a domain (www.bariscavusoglu.com) and set a provisional certificate to that domain and it still doesn't works.

I'm including the iOS app IDs section, ----> alt text

provisioning profiles section ----> alt text

and again the updated iOS Settings section. ----> alt text

Also I'm including the updated error lines:

 .....
 LogPlayLevel: DeploymentServer: [DD] ... Error: Failed to connect to bundle 'com.bariscavusoglu.
 .....
 LogPlayLevel: env: 2 DTDeviceKitBase 0x0000000110943441 -[DTDKMobileDeviceToken mountDeveloperDiskImage:withError:] + 782
 .....
 LogPlayLevel: env: 3 DTDeviceKitBase 0x0000000110943cf8 -[DTDKMobileDeviceToken mountDeveloperDiskImageWithError:] + 488
 .....
 LogPlayLevel: env: 2 DTDeviceKitBase 0x0000000110943441 -[DTDKMobileDeviceToken mountDeveloperDiskImage:withError:] + 782
 .....
 LogPlayLevel: env: 3 DTDeviceKitBase 0x0000000110943cf8 -[DTDKMobileDeviceToken mountDeveloperDiskImageWithError:] + 488
 .....
 LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: CodeSign Failed
 .....
 LogPlayLevel: RunUAT ERROR: AutomationTool was unable to run successfully.
 .....
 PackagingResults: Error: Launch failed! Failed to Code Sign
 .....
 


avatar image Sertac Ogan Dec 31 '17 at 10:27 AM

Should not be empty after the point on Unreal Project Settings. The star in the Apple Developer Panel means anything can happen. So, com.bariscavusoglu.testproject or anything.

avatar image bariscavusoglu Dec 31 '17 at 10:55 AM

I tried com.bariscavusoglu.testproject for the Bundle Identifier section.

I still get the same error,

 LogPlayLevel: DeploymentServer: [DD]  ... Error: Failed to connect to bundle 'com.bariscavusoglu.testproject'
avatar image bariscavusoglu Dec 31 '17 at 11:07 AM

What's driving me crazy is, it was working before.

I'm not sure but I think after deleting the test app directly from my iPhone, I started getting this error all of a sudden.

However I deleted it many times and nothing happened before.

avatar image Sertac Ogan Dec 31 '17 at 11:16 AM

Sometimes I was tired and coffee break. And when I returned, when I tried, it was working. This is hard to understand.

avatar image Sertac Ogan Dec 31 '17 at 11:13 AM

I understood, that weird. I have encountered many problems like this. There can be a lot of reasons. I hope your problem resolved as soon as possible.

avatar image bariscavusoglu Dec 31 '17 at 11:21 AM

Thanks for your help:)

avatar image bariscavusoglu Dec 31 '17 at 11:26 AM

Wait I found the problem! The problem is the Mobile location Services - iOS Plugin !?

I disabled it and now it launches on my phone. But it has to be enabled so that I can track players location.

I still don't get it. The location services plugin was working fine before.

avatar image Sertac Ogan Dec 31 '17 at 11:30 AM

Oh nice good to hear

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question