x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blizzard Particle not stopping on collision?

I am trying to make my Snow / Blizzard particle Kill on collision with a static mesh, but it seems to still go through and not Kill at all.

See Screenshots:

As you can see, the Snow is blowing straight through the walls without any collision. alt text

I have CPU Particles set up with "Actor Collision set to "Kill" but it does not seem to work...

How could I fix this?

Thanks in advance.

Product Version: UE 4.18
Tags:
snow.png (239.1 kB)
more ▼

asked Jan 02 '18 at 01:25 AM in Blueprint Scripting

avatar image

AzzaMatta2571
36 4 7 13

avatar image SouthBot Jan 02 '18 at 09:29 AM

Have you tried using the Deactivate component?

avatar image AzzaMatta2571 Jan 04 '18 at 01:20 AM

How do I find that?

avatar image SouthBot Jan 04 '18 at 10:01 AM

On second thoughts Deactivate will not do what you want. It will turn off all particles which is not the solllution

avatar image AzzaMatta2571 Jan 04 '18 at 10:35 AM

The object shown does have collision as it is a static mesh, and i have set the collision in the cascade to "kill", but still does not work, i have tested with a new particle system and it does work, but for some reason my P_Blizzard particle just goes through the object, may it be because the size of each particle is changed to 1600?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question