x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Save Game To Slot not creating a save file

I'm following along with the UE4 Multiplayer tutorials and I have come across an issue where the SaveGameToSlot function is not actually resulting in a save file being created (or even the SaveGames folder for that matter). I have no clue what I am doing wrong.

When I set a breakpoint on the function it does actually stop and seems to execute (no error) but then doesn't create the file. Here is the hookups: alt text

Product Version: UE 4.18
Tags:
ue4-issue.png (269.3 kB)
more ▼

asked Jan 02 '18 at 03:02 AM in Blueprint Scripting

avatar image

Xeru98
21 1 2 5

avatar image BladeMaster Jan 04 '18 at 08:12 PM

Is it showing any errors? Can you share your full BP?

avatar image Olof Jan 15 '18 at 01:39 PM

Any news on this? I also have this issue. Save Game to Slot does not create a save file or folder in my project.

avatar image Xeru98 Jan 15 '18 at 05:09 PM

Check my answer out below

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

So it turns out that I was just stupid an didn't check my work. In the picture I have a string node hooked up to the "save game to slot" "slot name" input. That string node has a NAME but not a default value. So while on the surface it looked fine. After some digging I found out that I had just forgotten to set the default value of my "Player Settings Save" node. Oh well, live and learn I guess.

more ▼

answered Jan 15 '18 at 05:12 PM

avatar image

Xeru98
21 1 2 5

avatar image rokkie199 Mar 30 '19 at 05:03 AM

Oh god I'm so stupid, tried to fix it for ages before I found your comment, I don't feel dumb at all. ...not. at. all.

Thank god for your comment!

(JK, thank you <3)

(comments are locked)
10|2000 characters needed characters left

Yes! Setting a default value for the String worked. You did NOT have to do this in earlier versions of Unreal though! That's what confused me.

more ▼

answered Jan 16 '18 at 01:48 PM

avatar image

Olof
1 1 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question