x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Scene capture 2D component not working in BP

Hi,

I just tried to setup a Blueprint that contains a SceneCapture2D component. While it is possible to add a capture component to the BP, it does not show the camera component in the viewport. Also it does not render anything to a provided texture target. When placed in the level on its own, the scene capuure component behaves as expected. But inside a BP it seems bugged.

Repro steps: - Create a blueprint based on actor - Add a SceneCapture2D component to the blueprint - Observe that only the transform widget is shown and the component does not behave as expected

Cheers, Klaus

Product Version: UE 4.18
Tags:
more ▼

asked Jan 04 '18 at 10:00 PM in Bug Reports

avatar image

KVogler
97 8 10 16

avatar image Grot13 Jan 05 '18 at 07:24 AM

I had a blueprint with a scene capture inside (with a render target assigned, I don't have camera), and it was rendered on an image widget. I believed that the blueprint had to be in world to activate the render target and to execute custom events and functions, but in fact no, everything was working although the Bp was not used in the level.

It works but it is not convenient to communicate, would have to cast each time (I finally added the BP to the world , far under the map, it was easier in my case.) Anyway try to create a render target and assign it to your scene capture, inside your bp

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey there, i tried creating a new Actor blueprint and added a SceneCaptureComponent2D, selected a Render Target and it's working fine (make sure you untick Alpha when viewing it).

more ▼

answered Jan 05 '18 at 11:57 AM

avatar image

xlar8or
5.9k 157 127 302

avatar image KVogler Jan 06 '18 at 04:02 AM

Hi,

Thanks for your answers. I know that a BP is just a class. Of course I dragged an instance into the level ;) When I place a 2d component in the BP it looks like this:

alt text

and the target remains black. Yes, I cunchecked alpha and all the materials that use the target also show black.

When I put a capture2D component in the level on its own, everything works as expected.. alt text

So I wonder: - Why is the camera not there in the BP viewport? - Why is the render target not correctly rendered?

charcambp.jpg (258.4 kB)
charcameditor.jpg (454.0 kB)
avatar image redbox Jan 06 '18 at 05:46 AM

Does it matter? That camera is just a mesh added to SC actor. Don't know why its not added to SC component, but if you need it, you can find it in Engine Content folder and add to this actor, or by modifying engine code, to default SC component.

avatar image AcidJackal Jan 13 '19 at 10:45 PM

That still doesn't answer the question of why the render target isn't rendering properly. I'm having the same issue.

avatar image Grot13 Jan 06 '18 at 09:38 AM

For me it works no matter if the bp is in the scene or if alpha is checked. Don't know why

avatar image xlar8or Jan 06 '18 at 11:53 AM

It works fine inside the blueprint editor aswell for me, i just have to make sure it's rotated properly.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question