x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Target Arm length doesn't work

Hi everyone,

I've stumbled across something I can't wrap my head around: I want my camera to zoom in and out via the mouse wheel. This should be a fairly easy thing to do; create a spring arm, attach your camera to it and then change the length of the target arm as necessary. Basic stuff, and I've done it in the past a few times. Well, now it doesn't work anymore.

alt text alt text alt text

As seen in the second image, the length of the arm does indeed change, but the camera doesn't move accordingly to it. Even weirder: If I change any other parameter - rotation, position, fov of the camera... - those changes work perfectly fine. The only thing that doesn't seem to have any effect whatsoever seems to be the target arm length, which decidedly doesn't make any sense to me.

Did I forget anything essentially to make this work or is there any work around?

Thank you in advance for your replies!

Product Version: UE 4.18
Tags:
ue4-bug-01.jpg (67.9 kB)
ue4-bug-02.jpg (62.5 kB)
ue4-bug-03.jpg (10.8 kB)
more ▼

asked Jan 07 '18 at 02:22 PM in Blueprint Scripting

avatar image

Datarecovery09
15 5 7 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

One explanation could be that the springarm's length is being set on Tick someplace else. Instead of printing it in this function, print the length in the Pawn's (or whatever object it's attached to) Tick and observe the value.

more ▼

answered Jan 07 '18 at 03:55 PM

avatar image

Everynone
15.2k 77 25 62

avatar image Datarecovery09 Jan 07 '18 at 07:19 PM

Thank you for your response! It didn't actually solve my problem, but pushed me into more weird stuff that didn't work. I migrated my work into a new project, and now it works. It seems like there was something broken with the project itself. Thank you nonetheless! :-)

avatar image Everynone Jan 07 '18 at 08:55 PM

Cool, glad to hear you got it working.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This problem may be caused by collision test, unchecking "Do Collision Test" in SpringArm's details and try again. alt text

ue4.jpg (7.9 kB)
more ▼

answered Apr 21 '18 at 05:53 AM

avatar image

zmcdn
11 1 2

avatar image amisner2k Oct 04 '18 at 08:32 PM

Thank you. This was my issue as well. I had "Do Collision Test" set to true. This option, according to the tooltip, is used to prevent the camera from clipping into the level. The spring arm appeared correct in the Blueprint Viewport tab and it worked fine when its actor was in a different level with a sky sphere in it, but it stopped working after I placed it in a new completely empty level (the arm length appeared to be locked to the bounds of the static mesh in my actor and could not be made to extend farther than that even though in the Blueprint Viewport it was shown correctly).

I'm guessing that the engine uses geometry in a level to determine its extents and since a completely empty level has no geometry in it (aside from a mesh in the actor itself), the spring arm will lock its arm length to the extents of the mesh on the actor.

This wasn't very intuitive as one would imagine an empty level as having no extents and thus no limit or bounds to restrict a spring arm to, but I suppose this was done for performance or some other underlying architectural/technical reason that I'm not privy to.

Either way, Thank you again zmcdn for this tip and I hope my findings help someone else as well.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I had similar problem. This happened after I create new game mode and new game state. Problem was I used just gamestate instead gamestatebase. After applying gamestatebase problem is gone. Absolutely have no idea how conect spring arm and game state but it works for me.

more ▼

answered Jul 18 '18 at 09:22 AM

avatar image

badlaba
11

avatar image litos333 Sep 22 '18 at 11:08 PM

Oh god, thank you so much. I had the exact same problem, and was due to the Game state. Don`t know why, but thank you so much man.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question