x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Critical Error thrown while packaging

Hey guys! I just wrapped an update up for my game on Steam, and I have run into a serious issue while packaging that I can't seem to resolve. Every time I try packaging, everything goes well for the first 3 or so minutes, and then I get this critical error and the build fails:

LogWindows: Windows GetLastError: The operation completed successfully. (0) LogThreadingWindows:Error: Runnable thread RenderThread 0 crashed. LogWindows:Error: begin: stack for UAT LogWindows:Error: === Critical error: === LogWindows:Error: LogWindows:Error: Assertion failed: (GIsCriticalError || !NumMarks) [File:D:\Build\++UE4+Release-4.16+Compile\Sync\Engine\Source\Runtime\Core\Public\Misc/MemStack.h] [Line: 90] LogWindows:Error: LogWindows:Error: LogWindows:Error: LogWindows:Error: LogWindows:Error: Crash in runnable thread RenderThread 0 LogWindows:Error: end: stack for UAT LogExit: Executing StaticShutdownAfterError LogWindows: FPlatformMisc::RequestExit(1) Log file closed, 01/07/18 21:32:47

This happens ever time no matter what I change. So far, I have tried the following:

  • Refreshing, recompiling, and saving all new blueprints

  • Setting "Build UAT" to 'true'

  • Packing via the file menu and the project launcher

  • Cooking while excluding certain maps

  • Restarting my PC

  • Restarting the editor

  • Recompiling C++

This may be something very simple or complex, and I am really hoping for some assistance. I have also attached the build log. Please let me know if I need to provide any additional information. Thankslink text

Product Version: UE 4.16
Tags:
more ▼

asked Jan 07 '18 at 06:57 PM in Packaging & Deployment

avatar image

warzone230
71 1 3 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question