x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

VIVE not working after a few minutes

Hello Guys, I've working on two VR projects, first project is an old project from 4.15 and the second project is newer and started from 4.17. My problem is I've to close the editor and then i must quit from SteamVR application (Reset SteamVR doesn't work and if i use restart i had to reset PC) and then starting the SteamVR and then start editor again to working on projects.

I had this problem from beginning with the 4.17 project even after updating to 4.18, but this problem occurs after updating old project from 4.15 to 4.18 Both projects are in C++. I don't know where is the problem but it's very annoying and waste my time.

Product Version: UE 4.18
Tags:
more ▼

asked Jan 08 '18 at 07:59 PM in VR

avatar image

Vahid
161 10 12 14

avatar image Vahid Jan 09 '18 at 04:21 PM

Any help ? I've reinstalled the VIVE software and also SteamVR but problem not solved.

avatar image magnusk Apr 24 '18 at 06:03 PM

I also have this problem, in 4.17. Haven't tried 4.18.

avatar image Vahid Apr 25 '18 at 05:14 AM

Unfortunately i couldn't find any solution for this even after changing my windows and reinstall all drivers and components, but my problem is now better and i don't need to restart everything after each playing time. I think after disconnect all wires and connect them again in HMD, helped me to fix the problem a little bit better than before this rewiring. this is not a final solution but maybe help you to have better experience.

avatar image magnusk Apr 26 '18 at 09:01 AM

Thanks for following up on this. I don't have to restart after every play session. Rather it seems like if I don't start a play session for some time, then the next play session the SteamVR HMD icon flashes and won't work. Sometimes it's the Vive controllers won't track, with gray SteamVR icons in this case. Could it be that SteamVR has a timeout after which it goes to sleep, after which UE4 can't wake it up? I'll have a look in the SteamVR settings for sleep timeout or similar.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question