x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Editor failing to check in/check out files from SVN server

Hi all,

Since a couple of days ago, we have been experiencing a very strange issue when trying to check in and check out files from the SVN server.

Here is the context of our SVN environment setup:

We have 1 server with the SVN repository, my colleague has his computer within the same network and I have my computer outside of the server's network (I connect to the server using dynamic DNS). We've had this setup for over a year now, and hadn't experienced issues until a couple of days ago.

The problem:

The strange part is that my colleague, can't check in or check out files from the server using the UE Editor. If he manually gets or releases the lock using Tortoise, everything works fine. What's even weirder is that I don't have issues with that being outside the network, I can check out and check in the files using the Editor. I even took my computer and put it inside the network (just like my colleague's computer) and everything worked fine. Also, if he manually checks out the file, we can see in the Engine that it's locked for editing, he edits, saves it and then checks the file in manually (using Tortoise), but when I refresh the Engine on my computer, I can't see the most recent changes.

So, I think we have narrowed it down to my colleague's Engine (or Computer?) but haven't been able to figure out the cause of this issue. Here are screenshots of the errors he gets:

alt text alt text

What we have tried, to no avail:

  • We retrieved a fresh new copy from the server, and put it in a different folder

  • We ran several times the clean up function that comes with Tortoise

  • We created a new username in the repository server and tried using those credentials instead of the usual ones for my colleague

  • Updated the engine to the latest version

  • Checked the files to make sure they are not read only (they are not)

At this point, we are not sure what else could the issue be, any help is definitely appreciated.

Thanks! Julio.

Product Version: UE 4.18
Tags:
01.png (31.0 kB)
02.png (20.0 kB)
more ▼

asked Jan 09 '18 at 12:45 AM in Using UE4

avatar image

Julio861128
26 1 5

avatar image Default816 Aug 01 '18 at 01:13 PM

Having the same problem here! I have a local SVN, but i can't for the life of me check out anything...Any solution?

avatar image Julio861128 Aug 01 '18 at 02:26 PM

We found out that the Source Control settings inside UE4, were pointing to an older repository folder, thus the issue of not being able to check files in or out using the Editor. After we changed to the correct settings, things went back to normal.

It's weird that the Source Control settings were changed, but we never really figured out why that happened.

avatar image Evil_Fischi Aug 01 '18 at 02:36 PM

I have more or less the same problem, are there any other options than clicking on the source control icon in the main toolbar to change those settings? Were you able to check in objects when the checkout was not working? I have the problem, that I can create new objects and commit them successfully, but I can not edit existing ones because I cannot check out them.

avatar image Julio861128 Aug 01 '18 at 02:52 PM

Hey Evil_Fischi,

When you commit new objects, you can't check them out later, or is the issue only present when you try to check out objects created before this issue started happening?

I'm not sure what you have already tried, but I would:

  • Use the Repo Browser to make sure the files are not locked (it's happened to me several times that this is not reflected in the Editor)

  • Use Tortoise to make sure it's pointing to the correct repository and using the correct credentials (it's not very likely that this is the issue, since you can commit new files, but it's better to make sure)

  • Run the cleanup function with your SVN client. I usually select the option to "break the locks", this has solve several of my issues in the past.

I'm curious to know what options you have tried to fix the issue.

avatar image Evil_Fischi Aug 01 '18 at 03:10 PM

Hi Julio,

I was never able to check out any asset. I am just irritated that I can add stuff, but not check out. I think this means, that I have the right path for the repository...

I have tripplechecked the folders for locks, but there are none.

Can it maybe be that the links starts with svn and not http? I think I stumbled across something like this somewhere

I cleaned up the folders too, so that they must be shine as hell now :/

But still it does not work.

Are there any settings i could stumple over in the svn server setup?`

By the way, here is a link to my question I asked some hours ago: https://answers.unrealengine.com/questions/814017/svn-checkout-not-working.html

Cheers Evil_Fischi

avatar image Julio861128 Aug 01 '18 at 03:17 PM

Thanks, Evil_Fischi, I'll take a look at your post.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question