x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blueprint compile error setting array element in Standalone only

I've got an array of this structure that I've created for my game:

alt text

If I try to edit an element in an array of those structures, like this:

alt text

It works totally fine when I run PIE, but when I run standalone I get the following error message in the log:

 [2018.01.11-16.40.15:991][  0]LogBlueprint: Warning: [Compiler Obelisk_EnergyCore] The structure cannot be broken using generic 'break' node  Break F_EnergyCoreConnect . Try use specialized 'break' function if available.
 [2018.01.11-16.40.15:991][  0]LogBlueprint: Error: [Compiler Obelisk_EnergyCore] The structure  Make F_EnergyCoreConnect  is not a BlueprintType. 
 [2018.01.11-16.40.15:993][  0]LogBlueprint: Warning: [Compiler Obelisk_EnergyCore] [0052.22] Compile of Obelisk_EnergyCore failed. 1 Fatal Issue(s) 1 Warning(s) [in 15 ms] (/Game/Props/Obelisk/Obelisk_EnergyCore.Obelisk_EnergyCore)

The actor just is "gone" (invisible, no collision) in Standalone, but I can still reference it in script. It's a gnarly issue that fails relatively silently. To make things even more complicated, I can place this actor in a brand new level and I don't have any issues. There must be some corrupt data/links in the level that's failing, so I'm not hopeful this will be reproduceable :/

Product Version: UE 4.18
Tags:
1.png (53.1 kB)
untitled.png (62.0 kB)
more ▼

asked Jan 11 '18 at 04:49 PM in Bug Reports

avatar image

Ryan Darcey
836 47 45 70

avatar image Sean L ♦♦ STAFF Jan 12 '18 at 03:18 PM

Hello,

We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://forums.unrealengine.com/unreal-engine/announcements-and-releases/1410408-unreal-engine-bug-submission-form

Thanks

avatar image ShiningCrusader Feb 10 '18 at 08:36 PM

I can confirm the "Make structure" node is the culprit. Same goes for the "Set members in structure" node. I'm running 4.18.2 (haven't updated to 4.18.3 since 4.19 is due soon).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

This is happening to me too in 4.21.2 - blueprints compile fine in the editor but fail to compile when launching standalone. As Ryan says, the game still runs but things just don't work, so it's a silent'ish failure.

Posting this as an "answer" even though it's still a workaround really, but it seems like the problem occurs with structs that contain a variable that is a non-native object class.

I had a three different structs that were failing to compile make/break nodes and all of them had a custom actor variable in them. Instead, I changed those variables to instead be just "Actor" type, then used a cast/interface instead when I needed to do things with those actors. The compile failure in standalone went away.

more ▼

answered Mar 21 '19 at 10:53 PM

avatar image

Spoondog
488 13 27 41

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question