x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

LODs not working?

I am trying to auto-generate 2-3 lods for my Trees in my game which I am testing on 1 tree at the moment but when I select 3 lods then set the group to foliage or even anything else and click apply nothing happens and it only says lod0 even though i can see in the drop down that I can manually select them but they're not listed above it except for lod0.

Is that a bug or does that mean my model is low enough that it should be okay? Any ideas?

Basically, I have what I think is a small open world map but originally I several non-overlapping trees to create a forest with about 40 of the tree presets fromt Tree & Plant Generator in the marketplace which looked nice and all along with several static meshes but the fps dropped to 22.

When I pulled out all of those trees I noticed it shot back up to 60. So now I am trying to make some improved trees and probably a lot less of them but i don't want it to look weird either with not enough so it looks forest-like.

Product Version: UE 4.18
Tags:
more ▼

asked Jan 12 '18 at 08:00 PM in Using UE4

avatar image

Deygus
97 9 20 19

avatar image Deygus Jan 12 '18 at 08:07 PM

Update -

I think I may have figured it out but it's just strange that I had to tick the custom box in the LOD Picker to enable them all to show up whereas the videos I watched in older versions of doing this just selected it and then they appeared so I thought it was a bug or something or maybe it changed, idk but at least i found a way to make it work now.

Sorry, still learning a lot on using UE4..

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I've found that just clicking "Apply Changes" with an LOD number set is not good enough. You also have to set the decimation percentage, then apply. This must be done on each LOD.

alt text

alt text

more ▼

answered Aug 20 '18 at 01:08 AM

avatar image

JonathanArmstrong
44 2 8

avatar image Deygus Aug 20 '18 at 12:50 PM

Ahhh okay, thank you, i'll give that a try. I was only doing the Number of LODs and clicking apply. I appreciate the help!!

avatar image JonathanArmstrong Aug 20 '18 at 06:26 PM

No problem! Another thing you could try is to use the preset dropdown for "LOD Group." This will set the number of LODs and their decimation percentages automatically. HighDetail is a good one, as it has 6 total LODs and each transition at fairly short distances.

I was also having an issue with foliage not switching to the next LOD until very far from the camera (you can see which LOD it's using by looking at the 3D viewport Heads-up display). Even with using a LOD group, the way certain assets are built for some reason have too far of LOD distances. At this point, you can manually enter the LOD distances by unchecking "Auto Compute LOD Distances" and set the "Screen Size" for each. Something like 0.25 for LOD1, 0.1 for LOD2, and .04 for LOD3 should do it.

avatar image JonathanArmstrong Aug 22 '18 at 06:17 PM

After further investigation, this appears to be a bug in the current versions of the engine. I was running version 4.15 and just upgraded to 4.20. The Auto LOD is not working. I am submitting a bug report for it, although the bug report form is down right now.

avatar image Deygus Aug 22 '18 at 06:23 PM

That's what I was kinda thinking because I tried it again and same issue. Seems about right for a bug but I wasn't sure if I was doing something wrong or not. I don't remember if I reported it. I think I ran into the same issue with the bug report form being down but it was awhile ago so I don't recall.

I found a way around it by setting it just as large or small asset but I don't quite think its as optimized since the object I was originally trying to use it for is a bunch of trees I created for a game project.

avatar image JonathanArmstrong Aug 23 '18 at 05:17 AM

Just got a response back from an Epic representative today about the bug. It is not a bug, but a UI update. To access all the individual LOD's, you have to check "Custom" under "LOD Picker." I believe the reason you're not seeing your trees switch models is because the auto-computed screen sizes are way too low/too far away from the camera.

alt text

You can display each LOD with the drop-down menu: LOD Picker>LOD>LOD Auto. Change this to LOD1, LOD2, etc. to display each LOD. "Custom" must be unchecked in this case, but you can always check it later and it will keep your custom LOD settings.

alt text

I am glad to know the the LOD tool is alive and well! :)

avatar image Deygus Aug 23 '18 at 03:48 PM

Ahhh.. okay, that makes sense now. Thank you so much for the additional effort that's very helpful and I really do appreciate it!!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question