x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

I'm having a problem with the Advanced Locomotion System v2.

It works fine in the editor, but when i tried it in the packaged game, the post process IK BP doesn't work. I created a new project and packaged it without any changes and the IK still doesn't work.

From looking at the output log i can't see any big problems regarding the IK BP.


https://drive.google.com/open?id=1KGXmdAPV5Z_oItQS15Q0bePaCBTnIe-P

Product Version: UE 4.18
Tags:
editor.png (2.2 MB)
packaged.png (1.2 MB)
more ▼

asked Jan 13 '18 at 12:26 AM in Using UE4

avatar image

YouE4
20 5 9 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Ok think I got it. The reason this was happening was due to the selection of virtual bones within the 'Two Bone IK' nodes. These are editor only and must be changed before building since the bone will be removed during the build process and the built package will have trouble reconciling this reference.

alt text

YouE4 - I think this is sufficient to mark this one as solved. Also you mentioned V3 does not have this issue.

more ▼

answered Jun 18 '18 at 09:43 AM

avatar image

Naveed
99 3 4 5

avatar image YouE4 Jun 18 '18 at 04:17 PM

Great job Naveed.

avatar image Konflict Feb 04 '19 at 12:15 AM

Correction, V3 has the very same issue once cooking the game with 4.20. Virtual bones are NOT editor-only they remain exists after packaging as well.

4.22 got some updates for the bone reference container, i'll report here back once it turns out this issue gets fixed for good.

avatar image ThirdEyeAgent Mar 31 '19 at 03:12 PM

Did u ever resolve it

avatar image Konflict Mar 31 '19 at 09:23 PM

Currently i'm using 4.20, therefore i had to manually craft the IK bone structure in external app to get it working. Virtual IK bones are a no go for 4.20.

Edit: worth to note, that using regular sockets and a bit of a tweaking on the code i was able to substitute the Joint target problem mentioned above, and it just works without using virtual ik bones on that property.

In my case, unfortunately the entire character is lacking of physical IK bones, therefore i setup the skeleton with virtual ik bones, which is not working out for me until this bug get's resolved.

alt text alt text

ikchar.jpg (66.8 kB)
iksetup.jpg (120.5 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

was this ever solved?

more ▼

answered Feb 12 '18 at 06:35 AM

avatar image

Swashbucklingfox
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I am seeing this in V2 as well. Anybody got around this?

more ▼

answered Jun 17 '18 at 11:21 AM

avatar image

Naveed
99 3 4 5

avatar image YouE4 Jun 17 '18 at 11:37 AM

I actually haven't experienced this issue lately, but you could try to activate "EnableFootIK" After the game has started. Maybe the entire PostProcess BP gets disabled when it starts. I have also used V3 and it doesn't seem to be an issue there.

avatar image Naveed Jun 17 '18 at 12:01 PM

Tried triggering that variable after a delay as in the image. Doesn't seem to fix it. I'll keep digging but thanks for the suggestion!

alt text

avatar image Naveed Jun 18 '18 at 09:11 AM

I've narrowed it down to the 'Two Bone IK' node not working properly. Still digging.

avatar image ThirdEyeAgent Mar 31 '19 at 03:10 PM

Please help I'm having the same issue and put a lot of work into my game already . I'm also packaging on 4.22 right now to see if it works

avatar image Konflict Mar 31 '19 at 09:21 PM

I haven't updated the project to 4.22 just yet. Can you confirm that the virtual bones references work with the IK in the new engine version?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question