x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Material Editor not previewing/crash upon saving

For all this time, i could modify, save and preview my materials without any trouble... but just recently my Material Editor started to behave in unexpected ways.

It does not preview the materials that i made, even if they are as simple as a Constant3vector connected to the Base Color. And it crashes upon saving or applying the material, this happens always, so i'm unable to make any changes to a material or make a new one. However, i can apply an existing material to a mesh without problems.

Also, the whole framerate of the game dropped a lot.

Product Version: UE 4.18
Tags:
more ▼

asked Jan 13 '18 at 06:46 PM in Bug Reports

avatar image

Sqrt 2
6 1 1

avatar image Blayze Kohime Jun 23 '18 at 12:58 PM

Any other information on this? Because I'm having the same issue. Any material, even a single color connected to base color, freezes. There's no crash, no log, it just stops. Reinstalling does nothing. Making a new 4.19.2 project does nothing. BUT it works fine in all 4.18 projects. What is it with 4.19? Because I'm having the same problem making landscapes in 4.19; every time I so much as go to the landscape tab in the editor it crashes.

avatar image xLetumx Jul 08 '18 at 05:59 AM

I have the same exact problem on 4.19.2 I haven't tried a different version. But everything I've tried nothing has worked. I've tried a new project, new material with simple const4vector color to base, NOTHING worked. I can literally only move a node, not make any changes and it will freeze when applying changes reaches 100%. In the same day, it had worked. I had done nothing that should have affected the material editor. No hardware changes, not setting changes. It's disheartening, I was really motivated until this happened. The only major system change that probably occurred before this happened, was an update to the latest windows insider deployment. Maybe this is where the issue is, I don't know.

As a side note, I should have zero problem with running the program. Running it with a threadripper 1950x, 64gb 3000mhz ram, amd 290x.

avatar image xLetumx Jul 08 '18 at 06:12 AM

I tried version 4.18.3 and there is no problem

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey there, you could try reinstalling the engine to see if that fixes it.

more ▼

answered Jan 14 '18 at 02:32 PM

avatar image

xlar8or
6k 159 127 303

avatar image Sqrt 2 Jan 19 '18 at 01:50 AM

It won't do anything.. it stills freezes when the ''applying changes to the world'' bar is fully loaded. It's weird because it worked perfectly a week ago.

avatar image xlar8or Jan 20 '18 at 05:50 PM

Does that happen with all materials?

avatar image Sqrt 2 Jan 23 '18 at 11:18 PM

All of them, even the simplest.

avatar image xlar8or Jan 24 '18 at 12:17 AM

If you have already reinstalled the engine, then you can try creating a new project to see if you still have the issue. If you do try to find a way to replicate the issue so that epic can look into it.

avatar image Sqrt 2 Jan 27 '18 at 01:14 AM

I reinstalled it, i made a new project... but it still crashes when the ''applying changes'' bar gets to 100% (of course, once i open the project it's not really saved), so it seems like it's unable to process the new material, since old materials done before the editor started crashing work with no problems.

It could be a problem with my CPU, but it doesn't really make sense since the materials i'm making are really basic... and my computer doesn't have too much trouble with playing the game (it lags a bit, but it doesn't crash). It's just the material editor.

avatar image xlar8or Jan 28 '18 at 09:40 AM

Can you install the debugger symbols and send a screenshot of the crash report screen?

avatar image Sqrt 2 Jan 29 '18 at 02:16 AM

The thing is... it's not really a crash within the engine... but actually a freezing (i kinda used the wrong terminology), Unreal Engine just freezes without ever responding when i save a material, i have to close it with the Task Manager.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question