x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Merge Actors - Texture quality is bad

Hi all,

I´m trying to save some performance (draw calls) by merging some meshes with multiple materials on it. for that i´m using the merge actor tool.

I´ve now tried various combinations but i end up every time with a merged mesh and blurry, looks-like low resolution textures.

Left original, right after merge The image shows on the left side the original with a texture size of 2048, on the right i set up the texture size to 2048 too. Even if i try higher resolutions, more or less additional maps accordingly the materials i´ve or baking the vertex color into, the result is every time a much lower quality texture

Here some more pictures alt text A little more zoomed in alt text From the side of the roof, you can see it good at the wood

Somebody knows the issue and can help me out there`?

Best regards, Maik

Product Version: UE 4.18
Tags:
more ▼

asked Jan 14 '18 at 07:19 PM in Rendering

avatar image

Krustenkaese
8 4 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

When you merge there is an option to Merge Materials. Merging materials also merges the texture maps. A 2k texture will fit 4 merged objects by laying out the textures in a 512 grid, 8 objects at 256px grid etc. to fit into the 2k map.

You can view this yourself by looking at the new textures in your content-browser. They will be aligned in a grid-like I have described.

EDIT: AFAIK To avoid this, you must combine your mesh outside of unreal and manually refit the UV's so you have one 2k texture for your whole object, otherwise you have to deal with the loss of quality as your texture is compressed to fit into the grid.

more ▼

answered Jan 15 '18 at 11:21 AM

avatar image

TristonS
44 5 4 9

avatar image Krustenkaese Jan 16 '18 at 08:24 AM

Thanks for the clarification, then i´ve to map the uv and align them properly with the textures to have it like before.

I guess then this feature is less for optimizing in focus object rather than background objects that are less important.

avatar image lanfranconi Mar 23 '19 at 03:29 PM

Proper English and sentence structure would allow other users like me to follow up more easily. It's hard to understand if and how the issue was solved.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question