x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Alot of spline meshes cause massive framerate drops

Hey,

I have a lot of spline meshes in my scene (around 125+), every mesh has low polygon count ( 21 tris ). I looked up everywhere and did everything that people said. 1. Make sure that it is set to static and not movable. 2. also checked to make sure it dosen't have collision (checked don't need it)

But I still suffer from massive framerate drops. Please helps.

Product Version: UE 4.18
Tags:
more ▼

asked Jan 14 '18 at 09:36 PM in Using UE4

avatar image

7todie
1 2 3

avatar image 7todie Jan 14 '18 at 11:10 PM

Nope, do you have 400 splines mesh directly in the angle of the viewport?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Interesting, with around 400 movable spline meshes @ 96 tris each and with a double sided translucent material I see absolutely no impact on performance whatsoever. And my PC is average by today's standards.

The only time when I can observe a hit to the fps is when I update the splines every frame. Are you doing something to the spline and the spline meshes during Tick?

more ▼

answered Jan 14 '18 at 10:49 PM

avatar image

Everynone
14.6k 76 25 61

avatar image Everynone Jan 15 '18 at 08:39 AM

Nope, do you have 400 splines mesh directly in the angle of the viewport?

I just gave it a quick test, with 13 objects, 36 spline meshes each (468 SMs in total / 96tris each / 2-sided, additive material).

If they're not being updated my fps sits around 270 whether I see them or not (yes, all of them - never noticed any impact). When everything starts moving during a Timeline sequence - the spline points are redistributed, the tangents recalculated and SMs reshaped, I lose around 20% - quite a big impact, yes but I've done no optimisation here yet.

edit: To give you a rough idea of what I'm talking about, the concentric circles here are the splines with their own respective SMs:

alt text

They are created dynamically at the beginning of the game. Previously I tried spawning them completely on the go but that brought everything to its knees. Instead, they are now alive all the time and either sit pretty or stay hidden.

While measuring everything in FPS is not really healthy and I should have given you ms, it does paint a half-decent picture of things working rather smoothly.

My question to you is: are you doing something to the spline meshes during tick, as in constantly updating / respawning them? Perhaps you're hitting the limits of your PC's performance. My machine has a fairly old GPU - 7970 and the second gen quad core. However, if you're trying to do it on a laptop, I can easily see it impacting performance quite dramatically.

untitled.png (119.9 kB)
avatar image Yashinski May 20 '19 at 02:04 PM

Hi I'm having the same problem, have you figured it out?

avatar image Ashh111 May 20 '19 at 02:35 PM

Check the material shadows off (it's sounding odd, but it is in the raw mesh's options). It won't solve the entire number of the possibly related problems, but it's one of the most that may cause the impact.

avatar image Yashinski May 20 '19 at 02:50 PM

Thanks, but I can't see any improvement :(

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

In my case it was the ShadowDepths that was killing the performance.

more ▼

answered May 13 '19 at 10:30 AM

avatar image

Ashh111
1 2 6 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question