x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4.3.1 Preview - Hot Recompile can't find "delayimp.lib"

I had posted this bug with my project like a week ago. It is fixed and everything works fine in VS2013.

But now the Hot Recompile compiler has this issue ; I assume only Epic can fix that? (in the Launcher Version)

Fix was: VS2013 Project Settings were missing $(LibraryPath)

Product Version: Not Selected
Tags:
more ▼

asked Jul 25 '14 at 05:13 PM in Bug Reports

avatar image

CAPTNCAPS
143 31 24 31

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi CAPTNCAPS,

I am not seeing this issue with the 4.3.1 preview. Can you tell me exactly what steps you take from creating a new project to seeing this error? Can you confirm that this is only happening in the Editor with a Hot Recompile? Building in Visual Studio does not cause any issues? Can you provide the build log when the error occurs?

more ▼

answered Jul 25 '14 at 07:36 PM

avatar image CAPTNCAPS Jul 25 '14 at 11:11 PM

I downloaded UE4.3.1 preview from the launcher and updated my project to this version. (was using 4.2 before) When I tried to Hot Recompile, Error LINK : fatal error LNK1181: cannot open input file 'delayimp.lib' ; no error appears in Visual Studio.

As I said ; I had this problem in VS2013 two weeks ago with my project. But I was able to fix it by adding "$(LibraryPath)" to the Project Settings. I cannot do that with the Engine, because it's the launcher verison. :)

avatar image Tim C ♦♦ STAFF Jul 29 '14 at 05:52 PM

Hi CAPTNCAPS,

I have not had any luck reproducing the error referring to delayimp.lib. The only error I was able to trigger was the expected one when making changes to a header file. Are you only experiencing this issue in your project, or do you see the same error in a new project from one of the templates?

avatar image CAPTNCAPS Jul 29 '14 at 06:48 PM

I just checked with the Shooter Game example and the Vehicle Game Unfortunately it gives me the header changes error. (which, in my project, also happens and therefor overrides the delayimp.lib error)

So I am unsure if it happens in other Projects Let's say no, what would I have to do to fix it?

avatar image Tim C ♦♦ STAFF Jul 30 '14 at 04:11 PM

Since we can't reproduce the error message, we have not yet been able to determine why the error is appearing for you. One thing you could please check for me. Does $(LibraryPath) still appear in the project settings within Visual Studio for your project? My project settings do not include that, and adding it does not seem to have any effect for me.

Another thing you can try that might be helpful. Download the attached file and place it in an empty folder on your desktop. Remove the .txt extension and run the file. It will create an info.txt file inside the folder. If you can upload that file here, that would be great.

avatar image CAPTNCAPS Jul 31 '14 at 09:49 AM

It was indeed still there. I tried removing it, and nothing changed. Compiling in VS2013 works, Hot Recompile doesn't. I attached the info file :)link text

info.txt (4.7 kB)
avatar image Tim C ♦♦ STAFF Aug 01 '14 at 03:20 PM

I noticed a couple things in the file that you uploaded. Go to your Windows Environment Variables (located at Control Panel\System and Security\System -> Advanced system settings -> Environment Variables). Locate the Path variable and add ;C:\Windows\System32 to the end (make sure to include the semi-colon).

Then locate your VS120COMNTOOLS environment variable and make sure it is pointing to the \Common7\Tools folder in your Visual Studio installation. It is a good idea to check to make sure the folder actually exists at the location the variable is pointing to. If this variable is not correct, change it to point to the correct folder location. I suspect that this variable is likely correct, but the Error message in the info.txt file you provided suggests that it may not be.

One last thing to check. I don't anticipate a problem here either, but in your Visual Studio installation, go to \VC\lib and see if you have delayimp.lib in that folder.

I am still trying to track down the root cause of this error message, and not being able to reproduce it myself is just making it more difficult.

avatar image CAPTNCAPS Aug 01 '14 at 05:44 PM

Ok, I added the sys32 path to the PATH variable. I checked the VS120COMMONTOOLS path, it's existing. And delayimp.lib is existing (else, I would get compile errors in VS2013, right?)

I just tried and it works now :P

Thank you

avatar image ELITdie Oct 03 '14 at 03:26 AM

Ok, Tim, hello! Can you help me with same problem? Hot Recompile doesn't work, but the compilation in VS2013 is alright. Path variable is correct, VS120COMNTOOLS too, delayimp.inc exists. info.txt attached to the mesage.link text

info.txt (6.4 kB)
avatar image Tim C ♦♦ STAFF Oct 03 '14 at 02:54 PM

Hi ELITdie,

I noticed that in your Path variable, you have C:\Windows\System32 listed twice. I don't think that is causing the issue you are seeing, but you can remove the second instance of that path at the end of your Path variable.

Is this something that was working for you previously and is now broken? What version of the Engine are you using, and is it the binary version installed by the Launcher, or did you build it from source code?

avatar image ELITdie Oct 06 '14 at 09:01 AM

Thanks for quick answer, Tim. I have UE 4.4.3, it's binary. Sorry for my last post, but I still can't build my project by VS2013 without write $(LibraryPath). Think that this problem in VS2013 is root of Hot Recompile problems :( There was from first UE4 and VS2013 installations. I have Windows 8 and Windows SDKs are installed.

avatar image Tim C ♦♦ STAFF Oct 06 '14 at 10:31 PM

Just a minor detail, but I want to make sure. You mentioned that you have a delayimp.inc file. Do you also have a delayimp.lib file?

avatar image Molion Mar 13 '15 at 04:19 PM

Hi, I'm basically in the same situation as ELITdie, except I am now using UE 4.7.2, attached info.txt link text. Any help would be greatly appreciated.

info.txt (8.4 kB)
avatar image Tim C ♦♦ STAFF Mar 17 '15 at 11:26 PM

Hi Molion,

The only way I have ever been able to trigger this error message was by removing all of the Executable Directories from the project properties. Adding those back in clears up the error and lets me build successfully.

Right-click on your project in the Solution Explorer in Visual Studio and select Properties at the bottom of the menu. Go to Configuration Properties -> VC++ Directories. For Executable Directories, click the down arrow at the end of the line and select the Edit option. Make sure the "Inherit from parent or project defaults" check box is checked.

Let me know if that doesn't work for you.

Tim

avatar image Molion Mar 25 '15 at 06:35 PM

New projects have the check box checked by default.

avatar image Tim C ♦♦ STAFF Apr 08 '15 at 09:50 PM

Hi Molion,

My apologies for not returning to this post sooner. Is this still a problem for you?

Tim

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question