x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Playing movie file on iOS

Hey,

I'm using UE 4.18.2, and I'm following this tutorial to play a movie file in 3D:

https://docs.unrealengine.com/latest/INT/Engine/MediaFramework/HowTo/FileMediaSource/

This works fine on macOS. However, when launching on iOS, I just get the default movie player material look (the one that I also see in the editor when the movie is not playing), and the movie never starts.

From the XCode log, I can see this error:

[2018.01.16-17.04.03:998][ 0]LogMediaAssets: Error: Failed to validate media source Sample (file://../../../UnrealTest/Content/Movies/sample.mp4)

I tried several different formats to see if anything works, but no luck so far. I'd love to hear any ideas on what I might be doing wrong and how to do this correctly.

The movie is located in Content/Movies/sample.mp4, 720p VBR h.264.

Cheers, Volker

Product Version: UE 4.18
Tags:
more ▼

asked Jan 16 '18 at 05:13 PM in Rendering

avatar image

volcore
36 1 3 4

avatar image gmpreussner STAFF Jan 18 '18 at 04:51 PM

Hi Volker, got a screenshot of your Blueprint? Also, what do you mean by default movie player material? It should just be black if nothing is loaded.

avatar image volcore Jan 18 '18 at 05:17 PM

Hi,

here is a screenshot:

alt text

We've now found out that the movie does play correctly when going through "Package Project -> iOS", and deploying the resulting IPA, but it does not work when going through "Launch -> My iPad".

Is there maybe a flag that needs to be set to tell the editor to copy over that asset when deploying through launch?

avatar image gmpreussner STAFF Jan 22 '18 at 03:11 PM

I think that iOS is not deploying the videos to the device when using PIE, only when creating a full package.

avatar image Gadorian Apr 03 '19 at 03:28 PM

Building the IPA worked for us too, thank you very much!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question