x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

GearVR app not using phone native resolution

I am having issues trying to get gearVR app to use native resolution of the device. I tried the solution to set r.MobileContentScaleFactor to 0 in both DefaultDeviceProfiles.ini file and in the engine-BaseDeviceProfiles.ini file but it is still setting it to 2080x1024. In the logcat file when the app starts, I do see render targets to support 2960x1440 in frame 1 but in frame 2 it is getting reallocated to 2080x1024. LogRenderer: Reallocating scene render targets to support 2960x1440 Format 10 NumSamples 2 (Frame:1). LogHMD: Allocating Oculus 2080 x 1024 rendertarget swapchain LogRenderer: Reallocating scene render targets to support 2080x1024 Format 2 NumSamples 2 (Frame:2).

Is there anything I am missing to set things up inside Unreal Project. BTW I am using Unreal Engine 4.18 version.

Thanks,

Product Version: UE 4.18
Tags:
more ▼

asked Jan 16 '18 at 07:10 PM in VR

avatar image

Parth Patel
6 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I think you need to set r.ScreenPercentage to 120

But I would wait until 4.19 which is in preview right now because it has a new and much simpler way for specify the resolution you want so any fix you might make now may be redundant in the new version anyway

https://forums.unrealengine.com/development-discussion/vr-ar-development/1401735-significant-changes-coming-to-vr-resolution-settings-in-4-19

more ▼

answered Jan 17 '18 at 03:44 PM

avatar image

gelliott
278 7 8 17

avatar image Parth Patel Jan 17 '18 at 04:31 PM

Thanks for replying. I didn't messed with screenpercentage because I also made GoogleVR Daydream app and in that when setting mobilecontentscalefactor to 0, it is using native resolution of the phone. I will try to test new vr.PixelDensity cvar to see the difference.

Thanks,

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question